aboutsummaryrefslogtreecommitdiffstats
path: root/x11-toolkits
diff options
context:
space:
mode:
Diffstat (limited to 'x11-toolkits')
-rw-r--r--x11-toolkits/gal2/Makefile6
-rw-r--r--x11-toolkits/gtkmathview/Makefile8
-rw-r--r--x11-toolkits/libgdiplus/Makefile4
-rw-r--r--x11-toolkits/ruby-wx/Makefile4
-rw-r--r--x11-toolkits/vdk/Makefile8
-rw-r--r--x11-toolkits/xscoop/Makefile8
6 files changed, 3 insertions, 35 deletions
diff --git a/x11-toolkits/gal2/Makefile b/x11-toolkits/gal2/Makefile
index a8886331c62a..7adc4706dd12 100644
--- a/x11-toolkits/gal2/Makefile
+++ b/x11-toolkits/gal2/Makefile
@@ -44,12 +44,6 @@ post-extract:
post-patch:
@${REINPLACE_CMD} -e '/^SUBDIRS/ s|docs||' ${WRKSRC}/Makefile.in
-.if ( ${OSVERSION} > 600000 && ${OSVERSION} < 600006 ) || \
- ( ${OSVERSION} < 503101 )
-.for po in da.po it.po zh_CN.po
- @${REINPLACE_CMD} -e 's|%-|%|g' ${WRKSRC}/po/${po}
-.endfor
-.endif
.include <bsd.port.post.mk>
diff --git a/x11-toolkits/gtkmathview/Makefile b/x11-toolkits/gtkmathview/Makefile
index 10a03417e879..9141876a76f9 100644
--- a/x11-toolkits/gtkmathview/Makefile
+++ b/x11-toolkits/gtkmathview/Makefile
@@ -32,10 +32,4 @@ USE_LDCONFIG= yes
MAN1= mathmlviewer.1
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 600000
-IGNORE= is unsupported on versions prior to FreeBSD 6.0
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/x11-toolkits/libgdiplus/Makefile b/x11-toolkits/libgdiplus/Makefile
index 7a7b71c72f6a..e17062559ffe 100644
--- a/x11-toolkits/libgdiplus/Makefile
+++ b/x11-toolkits/libgdiplus/Makefile
@@ -41,9 +41,5 @@ CONFIGURE_ENV+= CPPFLAGS="-I${LOCALBASE}/include" \
CFLAGS+= -fPIC
.endif
-.if ${OSVERSION} < 503000
-IGNORE= does not build and is useless without working Mono
-.endif
-
.include "${.CURDIR}/../../lang/mono/bsd.mono.mk"
.include <bsd.port.post.mk>
diff --git a/x11-toolkits/ruby-wx/Makefile b/x11-toolkits/ruby-wx/Makefile
index aac50ec186c8..080a9a652315 100644
--- a/x11-toolkits/ruby-wx/Makefile
+++ b/x11-toolkits/ruby-wx/Makefile
@@ -26,10 +26,6 @@ WX_COMPS= contrib
.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 500035
-BROKEN= "Cannot link: undefined versioned symbol name"
-.endif
-
WRKSRC= ${WRKDIR}/${DISTNAME}/src
DOCS= README README.linux ChangeLog
diff --git a/x11-toolkits/vdk/Makefile b/x11-toolkits/vdk/Makefile
index bb827a14f545..1acd234a23ab 100644
--- a/x11-toolkits/vdk/Makefile
+++ b/x11-toolkits/vdk/Makefile
@@ -29,12 +29,6 @@ LDFLAGS= -L${LOCALBASE}/lib -lgnuregex ${PTHREAD_LIBS}
.include <bsd.port.pre.mk>
-.if ${OSVERSION} > 502010
-GNU_REGEX_H= gnu/regex.h
-.else
-GNU_REGEX_H= gnuregex.h
-.endif
-
post-patch:
@${REINPLACE_CMD} -e \
's|CXXFLAGS="-s"|CXXFLAGS="$$CXXFLAGS"|g' ${WRKSRC}/configure
@@ -42,7 +36,7 @@ post-patch:
@${REINPLACE_CMD} -e 's|-lpthread|${LDFLAGS}|g' ${WRKSRC}/${file}
.endfor
.for file in vdk/FileDialog.h vdk/gtksourcebuffer.h vdk/gtksourcetag.h
- @${REINPLACE_CMD} -e 's|<regex\.h>|<${GNU_REGEX_H}>|g' ${WRKSRC}/${file}
+ @${REINPLACE_CMD} -e 's|<regex\.h>|<gnu/regex.h>|g' ${WRKSRC}/${file}
.endfor
@${REINPLACE_CMD} -e \
's|VDKComboEntry::||g' ${WRKSRC}/vdk/vdkcomboentry.h
diff --git a/x11-toolkits/xscoop/Makefile b/x11-toolkits/xscoop/Makefile
index 4e44cbd8daf0..e88f7569e4d5 100644
--- a/x11-toolkits/xscoop/Makefile
+++ b/x11-toolkits/xscoop/Makefile
@@ -24,14 +24,8 @@ ONLY_FOR_ARCHS= i386
.include <bsd.port.pre.mk>
-.if ${OSVERSION}>=600000
-EXEFILE= xscoop6
-.else
-EXEFILE= xscoop5
-.endif
-
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/${EXEFILE} ${PREFIX}/bin/xscoop
+ ${INSTALL_PROGRAM} ${WRKSRC}/xscoop6 ${PREFIX}/bin/xscoop
${INSTALL_MAN} ${WRKSRC}/xscoop.7 ${MAN7PREFIX}/man/man7/xscoop.7
@${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/xscoop.pdf ${DOCSDIR}/xscoop.pdf