aboutsummaryrefslogtreecommitdiffstats
path: root/x11-wm/dwm/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11-wm/dwm/Makefile')
-rw-r--r--x11-wm/dwm/Makefile14
1 files changed, 8 insertions, 6 deletions
diff --git a/x11-wm/dwm/Makefile b/x11-wm/dwm/Makefile
index b723e7ae4a3f..00c5765ffca8 100644
--- a/x11-wm/dwm/Makefile
+++ b/x11-wm/dwm/Makefile
@@ -3,13 +3,11 @@
PORTNAME= dwm
PORTVERSION= 6.1
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= x11-wm
MASTER_SITES= http://dl.suckless.org/${PORTNAME}/ \
http://schot.a-eskwadraat.nl/files/
-PATCH_SITES= http://dwm.suckless.org/patches/
-
MAINTAINER= 0mp@FreeBSD.org
COMMENT= Dynamic, small, fast and simple window manager
@@ -27,12 +25,16 @@ PLIST_FILES= bin/dwm \
man/man1/dwm.1.gz
PORTDOCS= README
-OPTIONS_DEFINE= XINERAMA DOCS SUPERASMODKEY VOLUMECONTROL
-OPTIONS_DEFAULT=XINERAMA
+OPTIONS_DEFINE= DMENUANDSTERM DOCS SUPERASMODKEY VOLUMECONTROL XINERAMA
+OPTIONS_DEFAULT=DMENUANDSTERM XINERAMA
+DMENUANDSTERM_DESC= Install x11/dmenu and x11/st as runtime dependencies
SUPERASMODKEY_DESC= Use Super instead of Alt for the dwm mod key
VOLUMECONTROL_DESC= Use keys on keyboard to raise or lower volume
+DMENUANDSTERM_RUN_DEPENDS= dmenu:x11/dmenu \
+ st:x11/sterm
+
SUPERASMODKEY_EXTRA_PATCHES= ${PATCHDIR}/superasmodkey-patch-config.def.h
VOLUMECONTROL_EXTRA_PATCHES= ${PATCHDIR}/volumecontrol-patch-config.def.h
@@ -51,7 +53,7 @@ post-extract:
fi
post-install:
- ${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/dwm
+ @${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/dwm
post-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}