aboutsummaryrefslogtreecommitdiffstats
path: root/x11-wm/e-module-places/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11-wm/e-module-places/Makefile')
-rw-r--r--x11-wm/e-module-places/Makefile35
1 files changed, 35 insertions, 0 deletions
diff --git a/x11-wm/e-module-places/Makefile b/x11-wm/e-module-places/Makefile
new file mode 100644
index 000000000000..23680d8986fd
--- /dev/null
+++ b/x11-wm/e-module-places/Makefile
@@ -0,0 +1,35 @@
+# Created by: Grzegorz Blach <gblach@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= e-module-places
+PORTVERSION= 20140911
+CATEGORIES= x11-wm enlightenment
+MASTER_SITES= LOCAL/gblach/enlightenment/
+
+MAINTAINER= gblach@FreeBSD.org
+COMMENT= Enlightenment module to manage disk volumes
+
+BUILD_DEPENDS= enlightenment:${PORTSDIR}/x11-wm/enlightenment
+RUN_DEPENDS= enlightenment:${PORTSDIR}/x11-wm/enlightenment
+
+DIST_SUBDIR= enlightenment
+GNU_CONFIGURE= yes
+USES= gmake libtool pkgconfig tar:xz
+INSTALL_TARGET= install-strip
+
+.include "../enlightenment/Makefile.plist"
+
+OPTIONS_DEFINE= NLS
+
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MNLS}
+USES+= gettext
+CONFIGURE_ARGS+=--enable-nls
+PLIST_SUB+= NLS=""
+.else
+CONFIGURE_ARGS+=--disable-nls
+PLIST_SUB+= NLS="@comment "
+.endif
+
+.include <bsd.port.mk>