aboutsummaryrefslogtreecommitdiffstats
path: root/x11-wm/e16/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11-wm/e16/Makefile')
-rw-r--r--x11-wm/e16/Makefile49
1 files changed, 38 insertions, 11 deletions
diff --git a/x11-wm/e16/Makefile b/x11-wm/e16/Makefile
index 927a394951a5..ff745385171e 100644
--- a/x11-wm/e16/Makefile
+++ b/x11-wm/e16/Makefile
@@ -6,29 +6,58 @@
#
PORTNAME= enlightenment
-PORTVERSION= 0.16.7.2
-PORTREVISION= 2
+PORTVERSION= 0.16.8
CATEGORIES= x11-wm
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
+DISTNAME= e16-${PORTVERSION}
MAINTAINER= vanilla@FreeBSD.org
COMMENT= A very artistic X window manager
LIB_DEPENDS= Imlib2.3:${PORTSDIR}/graphics/imlib2
-CONFLICTS= x11-wm/enlightenment-devel
-USE_REINPLACE= yes
+DATADIR= ${PREFIX}/share/e16
+
+CONFLICTS= x11-wm/enlightenment-devel-[0-9]*
USE_X_PREFIX= yes
-USE_GNOME= esound
USE_ICONV= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --enable-fsstd --disable-hints-gnome --disable-hints-kde
+CONFIGURE_ARGS= --enable-fsstd --disable-esdtest --disable-dependency-tracking \
+ --disable-rpath
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib -L${X11BASE}/lib"
-MAN1= enlightenment.1
+.if !defined(WITHOUT_ESOUND)
+USE_GNOME= esound
+.else
+CONFIGURE_ARGS+=--disable-sound
+.endif
+
+.if !defined(WITHOUT_NLS)
+USE_GETTEXT= yes
+PLIST_FILES= share/locale/bg/LC_MESSAGES/e16.mo \
+ share/locale/bs/LC_MESSAGES/e16.mo \
+ share/locale/da/LC_MESSAGES/e16.mo \
+ share/locale/de/LC_MESSAGES/e16.mo \
+ share/locale/en_US/LC_MESSAGES/e16.mo \
+ share/locale/es/LC_MESSAGES/e16.mo \
+ share/locale/fr/LC_MESSAGES/e16.mo \
+ share/locale/hu/LC_MESSAGES/e16.mo \
+ share/locale/ja/LC_MESSAGES/e16.mo \
+ share/locale/ko/LC_MESSAGES/e16.mo \
+ share/locale/nl/LC_MESSAGES/e16.mo \
+ share/locale/no/LC_MESSAGES/e16.mo \
+ share/locale/pl/LC_MESSAGES/e16.mo \
+ share/locale/pt/LC_MESSAGES/e16.mo \
+ share/locale/pt_BR/LC_MESSAGES/e16.mo \
+ share/locale/ru/LC_MESSAGES/e16.mo \
+ share/locale/sv/LC_MESSAGES/e16.mo \
+ share/locale/tr/LC_MESSAGES/e16.mo
+.else
+CONFIGURE_ARGS+=--disable-nls
+.endif
.include <bsd.port.pre.mk>
@@ -37,9 +66,7 @@ CONFIGURE_ARGS+= --disable-zoom
.endif
post-patch:
- @${REINPLACE_CMD} -e 's| wctype.h||g ; \
- s|-ldl||g' ${WRKSRC}/configure
- @${REINPLACE_CMD} -e 's|%%PREFIX%%|${PREFIX}|g' \
- ${WRKSRC}/scripts/e_gen_menu
+ @${REINPLACE_CMD} -e 's|%%X11BASE%%|${X11BASE}|g' \
+ -e 's|%%PREFIX%%|${PREFIX}|g' ${WRKSRC}/scripts/e_gen_menu
.include <bsd.port.post.mk>