aboutsummaryrefslogtreecommitdiffstats
path: root/x11-wm/e16/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11-wm/e16/Makefile')
-rw-r--r--x11-wm/e16/Makefile18
1 files changed, 10 insertions, 8 deletions
diff --git a/x11-wm/e16/Makefile b/x11-wm/e16/Makefile
index 65fa2268b8fe..59d6dfa2871b 100644
--- a/x11-wm/e16/Makefile
+++ b/x11-wm/e16/Makefile
@@ -2,8 +2,8 @@
# $FreeBSD$
PORTNAME= e16
-PORTVERSION= 1.0.18
-PORTREVISION= 1
+PORTVERSION= 1.0.19
+PORTREVISION= 0
CATEGORIES= x11-wm enlightenment
MASTER_SITES= SF/enlightenment/${PORTNAME}/${PORTVERSION}/
@@ -15,27 +15,29 @@ LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libImlib2.so:graphics/imlib2
-OPTIONS_DEFINE= DOCS NLS SOUND
+OPTIONS_DEFINE= DOCS NLS PANGO SOUND
OPTIONS_SUB= yes
-SOUND_DESC= Sound support via pulseaudio/libsndfile
SOUND_LIB_DEPENDS= libpulse.so:audio/pulseaudio \
libsndfile.so:audio/libsndfile
-SOUND_CONFIGURE_ON= --enable-sound \
- --enable-sound-pulse \
+SOUND_CONFIGURE_ON= --enable-sound=pulseaudio \
--with-sndldr=sndfile
SOUND_CONFIGURE_OFF= --disable-sound \
--with-sndldr=none
NLS_USES= gettext
NLS_CONFIGURE_OFF= --disable-nls
+PANGO_USE= GNOME=pango
+PANGO_CONFIGURE_ENABLE= pango
DOCS_CONFIGURE_ON= --enable-docs=yes
DOCS_CONFIGURE_OFF= --enable-docs=no
+USES= gmake iconv libtool gnome perl5 pkgconfig shebangfix
+
USE_XORG= ice sm xorgproto x11 xbitmaps \
xcomposite xdamage xext xfixes xft xinerama xrandr xrender \
xxf86vm
-USES= gettext gmake iconv libtool perl5 pkgconfig shebangfix
SHEBANG_FILES= scripts/e_gen_menu
-CFLAGS+= -Wno-unused-parameter
+CFLAGS+= -Wno-unused-parameter -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --disable-dependency-tracking \
--disable-rpath --enable-mans SHELL=/bin/sh