aboutsummaryrefslogtreecommitdiffstats
path: root/x11-wm/fvwm24/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11-wm/fvwm24/Makefile')
-rw-r--r--x11-wm/fvwm24/Makefile10
1 files changed, 9 insertions, 1 deletions
diff --git a/x11-wm/fvwm24/Makefile b/x11-wm/fvwm24/Makefile
index e0b523991a59..72e59ee515c1 100644
--- a/x11-wm/fvwm24/Makefile
+++ b/x11-wm/fvwm24/Makefile
@@ -36,6 +36,14 @@ CONFIGURE_ARGS+= --with-stroke --with-stroke-library=${LOCALBASE}/lib \
--with-stroke-includes=${LOCALBASE}/include
.endif
+.if defined(WITHOUT_SESSION_MGMT)
+CONFIGURE_ARGS+= --disable-sm
+.endif
+
+.if defined(WITHOUT_SHAPE)
+CONFIGURE_ARGS+= --disable-shape
+.endif
+
PLIST_SUB+= FVWM_VERSION="${PORTVERSION}"
.include <bsd.port.pre.mk>
@@ -44,7 +52,7 @@ PLIST_SUB+= FVWM_VERSION="${PORTVERSION}"
USE_GNOME= yes
PLIST_SUB+= GNOMEDATADIR="share/gnome/fvwm"
.else
-CONFIGURE_ARGS+= --without-gnome
+CONFIGURE_ARGS+= --without-gnome --disable-gnome-hints
PLIST_SUB+= GNOMEDATADIR="share/fvwm"
.endif