aboutsummaryrefslogtreecommitdiffstats
path: root/x11-wm/ion-3/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11-wm/ion-3/Makefile')
-rw-r--r--x11-wm/ion-3/Makefile53
1 files changed, 42 insertions, 11 deletions
diff --git a/x11-wm/ion-3/Makefile b/x11-wm/ion-3/Makefile
index 2f81d41200c0..3c5e9bb2299a 100644
--- a/x11-wm/ion-3/Makefile
+++ b/x11-wm/ion-3/Makefile
@@ -5,38 +5,69 @@
# $FreeBSD$
#
-PORTNAME= ion-3ds
-PORTVERSION= 20070318
-PORTREVISION= 1
+PORTNAME= ion-3rc
+PORTVERSION= 20070608
CATEGORIES= x11-wm
-MASTER_SITES= http://modeemi.fi/~tuomov/dl/
+MASTER_SITES= http://modeemi.fi/~tuomov/dl/:ion3 \
+ http://wannabehacker.com/src/:xinerama
+DISTNAME= ion-3rc-${PORTVERSION}
+DISTFILES= ${DISTNAME}${EXTRACT_SUFX}:ion3
MAINTAINER= philip@FreeBSD.org
COMMENT= The development version of the Ion window manager
RUN_DEPENDS= run-mailcap:${PORTSDIR}/misc/mime-support
-USE_X_PREFIX= yes
-USE_GETTEXT= yes
+CONFLICTS= ion-3ds-200*
+
+USE_XLIB= yes
USE_GMAKE= yes
USE_LUA= 5.1
MAKE_ENV= DEFINES="${IONDEFINES}"
.if defined(WITHOUT_NLS)
IONDEFINES+= -DCF_NO_LOCALE
+PLIST_SUB+= NLS="@comment "
+.else
+USE_GETTEXT= yes
+PLIST_SUB+= NLS=""
+.endif
+.if !defined(WITH_XINERAMA)
+PLIST_SUB+= XINERAMA="@comment "
+.else
+PLIST_SUB+= XINERAMA=""
+DISTFILES+= mod_xinerama-20070430${EXTRACT_SUFX}:xinerama
.endif
MAN1= ion3.1 pwm3.1
-MANLANG= "" fi cs de
-DOCSDIR= share/doc/ion3
+MANLANG= "" fi cs
-# NO, I don't want to use configure but ion's author system.mk
+# Use our own system.mk, instead of the one generated by configure
do-configure:
.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 500000
-IGNORE= needs wide character string functions in libc
+post-extract:
+.if defined(WITH_XINERAMA)
+ @${MV} ${WRKDIR}/mod_xinerama-3 ${WRKSRC}/mod_xinerama
+.endif
+
+post-patch:
+.if defined(NOPORTDOCS)
+ @${REINPLACE_CMD} -e 's|^_install:|dont&|' ${WRKSRC}/Makefile
+.endif
+.if defined(WITHOUT_NLS)
+ @${REINPLACE_CMD} -e 's| po | |' ${WRKSRC}/Makefile
+.endif
+.if defined(WITH_XINERAMA)
+ @${REINPLACE_CMD} -e 's|^MODULE_LIST =|& mod_xinerama|' \
+ ${WRKSRC}/modulelist.mk
+.endif
+
+post-install:
+.if defined(WITH_XINERAMA) && !defined(NOPORTDOCS)
+ ${INSTALL_DATA} ${WRKSRC}/mod_xinerama/README \
+ ${DOCSDIR}/README.mod_xinerama
.endif
.include <bsd.port.post.mk>