aboutsummaryrefslogtreecommitdiffstats
path: root/x11-wm/mate-window-manager/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11-wm/mate-window-manager/Makefile')
-rw-r--r--x11-wm/mate-window-manager/Makefile35
1 files changed, 35 insertions, 0 deletions
diff --git a/x11-wm/mate-window-manager/Makefile b/x11-wm/mate-window-manager/Makefile
new file mode 100644
index 000000000000..0e5c16815b19
--- /dev/null
+++ b/x11-wm/mate-window-manager/Makefile
@@ -0,0 +1,35 @@
+# Created by: Garrett Rooney <rooneg@electricjellyfish.net>
+# $FreeBSD$
+
+PORTNAME= mate-window-manager
+PORTVERSION= 1.6.2
+CATEGORIES= x11-wm mate
+MASTER_SITES= MATE
+DIST_SUBDIR= mate
+
+MAINTAINER= gnome@FreeBSD.org
+COMMENT= Window manager for the adult in you
+
+LIB_DEPENDS= libstartup-notification-1.so:${PORTSDIR}/x11/startup-notification \
+ libcanberra-gtk.so:${PORTSDIR}/audio/libcanberra
+
+PORTSCOUT= limitw:1,even
+
+USES= gettext gmake pathfix pkgconfig
+USE_XZ= yes
+USE_MATE= dialogs docutils
+USE_XORG= x11 xcomposite xcursor xdamage xrandr
+USE_GNOME= gdkpixbuf2 glib20 gnomehier gtk20 intlhack ltverhack pango
+USE_LDCONFIG= yes
+USE_AUTOTOOLS= libtool
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --with-gtk=2.0
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+
+GLIB_SCHEMAS= org.mate.marco.gschema.xml
+
+post-install:
+ @${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libmarco-private.so.0
+
+.include <bsd.port.mk>