aboutsummaryrefslogtreecommitdiffstats
path: root/x11-wm/metacity/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11-wm/metacity/Makefile')
-rw-r--r--x11-wm/metacity/Makefile14
1 files changed, 4 insertions, 10 deletions
diff --git a/x11-wm/metacity/Makefile b/x11-wm/metacity/Makefile
index 305cf8f8c428..405dcf3d870d 100644
--- a/x11-wm/metacity/Makefile
+++ b/x11-wm/metacity/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= metacity
-PORTVERSION= 2.3.987
+PORTVERSION= 2.4.0
CATEGORIES= x11-wm
MASTER_SITES= http://people.redhat.com/~hp/metacity/
DIST_SUBDIR= gnome2
@@ -21,20 +21,14 @@ USE_X_PREFIX= yes
USE_GMAKE= yes
USE_REINPLACE= yes
USE_LIBTOOL= yes
-CONFIGURE_ARGS= --localstatedir=${PREFIX}/share/gnome \
- --datadir=${PREFIX}/share/gnome \
- --disable-gtk-doc
+USE_GNOMENG= yes
+USE_GNOME= gnomeprefix gnomehack gnomehier
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include" \
LIBS="-L${LOCALBASE}/lib"
CONFIGURE_TARGET= --target=${MACHINE_ARCH}-unknown-freebsd${OSREL}
-pre-patch:
+post-patch:
@${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
- @find ${WRKSRC} -name "Makefile.in*" | xargs ${REINPLACE_CMD} -e \
- 's|[(]datadir[)]/gnome/|(datadir)/|g ; \
- s|[(]libdir[)]/pkgconfig|(prefix)/libdata/pkgconfig|g ; \
- s|[(]libdir[)]/bonobo/servers|(prefix)/libdata/bonobo/servers|g ; \
- s|[(]datadir[)]/locale|(prefix)/share/locale|g'
.include <bsd.port.mk>