aboutsummaryrefslogtreecommitdiffstats
path: root/x11-wm/openbox/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11-wm/openbox/Makefile')
-rw-r--r--x11-wm/openbox/Makefile43
1 files changed, 17 insertions, 26 deletions
diff --git a/x11-wm/openbox/Makefile b/x11-wm/openbox/Makefile
index 3c0137106e70..f464cec86e0a 100644
--- a/x11-wm/openbox/Makefile
+++ b/x11-wm/openbox/Makefile
@@ -18,40 +18,31 @@ USE_GNOME= glib20 libxml2 gnomehack ltverhack
USE_XORG= xft
USE_AUTOTOOLS= libtool
USE_LDCONFIG= yes
-CONFIGURE_ENV= CFLAGS+="-I${LOCALBASE}/include" \
- LDFLAGS+="-L${LOCALBASE}/lib"
-MAN1= openbox.1 openbox-session.1 obxprop.1 \
- openbox-gnome-session.1 openbox-kde-session.1
+
+CFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
PLIST_SUB= VERSION=${PORTVERSION:C/.[0-9]+\$//}
-NO_STAGE= yes
-.include <bsd.port.options.mk>
+OPTIONS_DEFINE= NLS IMLIB PANGO NOTIFY
+OPTIONS_DEFAULT= IMLIB PANGO NOTIFY
+OPTIONS_SUB= yes
-.if ${PORT_OPTIONS:MNLS}
-USES+= gettext
-PLIST_SUB+= NLS=""
-.else
-CONFIGURE_ARGS+= --disable-nls
-PLIST_SUB+= NLS="@comment "
-.endif
+NLS_USES= gettext
+NLS_CONFIGURE_OFF= --disable-nls
-.if !defined(WITHOUT_IMLIB)
-USE_EFL= imlib2
-.else
-CONFIGURE_ARGS+= --disable-imlib2
-.endif
+PANGO_USE= GNOME=pango
+PANG_CONFIGURE_OFF= --disable-pango
-.if !defined(WITHOUT_PANGO)
-USE_GNOME+= pango
-.else
-CONFIGURE_ARGS+= --disable-pango
-.endif
+NOTIFY_LIB_DEPENDS= libstartup-notification-1.so:${PORTSDIR}/x11/startup-notification
+NOTIFY_CONFIGURE_OFF= --disable-startup-notification
-.if !defined(WITHOUT_STARTUP_NOTIFICATION)
-LIB_DEPENDS+= startup-notification-1:${PORTSDIR}/x11/startup-notification
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MIMLIB}
+USE_EFL= imlib2
.else
-CONFIGURE_ARGS+= --disable-startup-notification
+CONFIGURE_ARGS+= --disable-imlib2
.endif
post-configure: