aboutsummaryrefslogtreecommitdiffstats
path: root/x11-wm/vtwm/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11-wm/vtwm/Makefile')
-rw-r--r--x11-wm/vtwm/Makefile18
1 files changed, 15 insertions, 3 deletions
diff --git a/x11-wm/vtwm/Makefile b/x11-wm/vtwm/Makefile
index c256afc55f03..213b238131d5 100644
--- a/x11-wm/vtwm/Makefile
+++ b/x11-wm/vtwm/Makefile
@@ -13,11 +13,23 @@ MASTER_SITES= http://www.vtwm.org/downloads/
MAINTAINER= ports@FreeBSD.org
COMMENT= Twm with a virtual desktop and optional Motif-like features
-LIB_DEPENDS= rplay.1:${PORTSDIR}/audio/rplay
-
USE_IMAKE= yes
USE_XPM= yes
MAN1= vtwm.1
-.include <bsd.port.mk>
+OPTIONS= SOUND "Sound support" on
+
+.include <bsd.port.pre.mk>
+
+post-patch:
+.if defined(WITHOUT_SOUND)
+ @${REINPLACE_CMD} -i "" -e \
+ 's:^XCOMM NO_SOUND_SUPPORT: NO_SOUND_SUPPORT:; \
+ s:^SOUNDLIB:XCOMM SOUNDLIB:; \
+ s:^SOUNDINC:XCOMM SOUNDINC: ' ${WRKSRC}/Imakefile
+.else
+LIB_DEPENDS+= rplay.1:${PORTSDIR}/audio/rplay
+.endif
+
+.include <bsd.port.post.mk>