aboutsummaryrefslogtreecommitdiffstats
path: root/x11-wm/windowmaker/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11-wm/windowmaker/Makefile')
-rw-r--r--x11-wm/windowmaker/Makefile27
1 files changed, 21 insertions, 6 deletions
diff --git a/x11-wm/windowmaker/Makefile b/x11-wm/windowmaker/Makefile
index ac9460fb5d6d..83d8d6bedbaf 100644
--- a/x11-wm/windowmaker/Makefile
+++ b/x11-wm/windowmaker/Makefile
@@ -1,12 +1,12 @@
# New ports collection makefile for: WindowMaker
-# Version required: 0.16.1
+# Version required: 0.17.5
# Date created: August 13, 1997
# Whom: handy@physics.montana.edu
#
-# $Id: Makefile,v 1.15 1998/07/03 06:51:19 tg Exp $
+# $Id: Makefile,v 1.16 1998/07/08 14:48:52 tg Exp $
-DISTNAME= WindowMaker-0.16.1
-PKGNAME= windowmaker-0.16.1
+DISTNAME= WindowMaker-0.17.5
+PKGNAME= windowmaker-0.17.5
CATEGORIES= x11
MASTER_SITES= ftp://ftp.windowmaker.org/pub/beta/srcs/ \
ftp://ftp.io.com/pub/mirror/windowmaker/beta/srcs/ \
@@ -14,7 +14,6 @@ MASTER_SITES= ftp://ftp.windowmaker.org/pub/beta/srcs/ \
MAINTAINER= handy@physics.montana.edu
-BUILD_DEPENDS= ${PREFIX}/lib/libPropList.a:${PORTSDIR}/devel/libproplist
LIB_DEPENDS= Xpm\\.4\\.:${PORTSDIR}/graphics/xpm \
jpeg\\.9\\.:${PORTSDIR}/graphics/jpeg \
png\\.2\\.:${PORTSDIR}/graphics/png \
@@ -25,7 +24,23 @@ GNU_CONFIGURE= yes
CONFIGURE_ENV= X11BASE=${X11BASE}
CONFIGURE_ARGS= --with-pixmapdir=${PREFIX}/include/X11/pixmaps \
--with-nlsdir=${LOCALBASE}/lib/locale \
- --with-gfx-libs=-L${LOCALBASE}/lib \
+ --with-gfx-libs="-L${LOCALBASE}/lib -ltiff34" \
--with-gfx-incs="-I${LOCALBASE}/include/tiff34 -I${LOCALBASE}/include"
+post-extract:
+ cd ${WRKSRC}; ${EXTRACT_CMD} ${EXTRACT_BEFORE_ARGS} libPropList.tar.gz
+
+pre-configure:
+ @(cd ${WRKSRC}/libPropList && CC="${CC}" CXX="${CXX}" \
+ ac_cv_path_CC="${CC}" CFLAGS="${CFLAGS} -fPIC" \
+ INSTALL="/usr/bin/install -c -o ${BINOWN} -g ${BINGRP}" \
+ INSTALL_DATA="${INSTALL_DATA}" \
+ INSTALL_PROGRAM="${INSTALL_PROGRAM}" \
+ INSTALL_SCRIPT="${INSTALL_SCRIPT}" \
+ ${CONFIGURE_ENV} ./${CONFIGURE_SCRIPT} ${CONFIGURE_ARGS}; \
+ make)
+
+pre-install:
+ @(cd ${WRKSRC}/libPropList; ${MAKE} install)
+
.include <bsd.port.mk>