aboutsummaryrefslogtreecommitdiffstats
path: root/x11-wm/windowmaker/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11-wm/windowmaker/Makefile')
-rw-r--r--x11-wm/windowmaker/Makefile9
1 files changed, 7 insertions, 2 deletions
diff --git a/x11-wm/windowmaker/Makefile b/x11-wm/windowmaker/Makefile
index 9fa3e753274f..8b1b11541300 100644
--- a/x11-wm/windowmaker/Makefile
+++ b/x11-wm/windowmaker/Makefile
@@ -39,7 +39,7 @@ CONFIGURE_ARGS= --with-pixmapdir=${PREFIX}/include/X11/pixmaps \
--with-incs-from="-I${LOCALBASE}/include" \
--with-gnustepdir="${PREFIX}/GNUstep" \
--disable-debug
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
MANLANG= "" sk
MAN1= geticonset.1x getstyle.1x seticons.1x setstyle.1x wdwrite.1x \
@@ -48,7 +48,8 @@ MAN1= geticonset.1x getstyle.1x seticons.1x setstyle.1x wdwrite.1x \
OPTIONS= XINERAMA "Enable xinerama support" off \
XKB_STATUS "XKB keyboard language status support" off \
WM_SINGLE_CLICK "Add single-click option to WPrefs menu" on \
- WM_LINGUAS "Enable support for additional locales" off
+ WM_LINGUAS "Enable support for additional locales" off \
+ DOCKHOTKEYS "Enable support for hotkeys on docks" off
.include <bsd.port.pre.mk>
@@ -76,6 +77,10 @@ PLIST_SUB= WM_LINGUAS=""
PLIST_SUB= WM_LINGUAS="@comment "
.endif
+.if defined(WITH_DOCKHOTKEYS)
+EXTRA_PATCHES+= ${FILESDIR}/extra_dockhotkeys.patch
+.endif
+
post-patch:
@${REINPLACE_CMD} -e "s|%%PREFIX%%|${PREFIX}|g" ${WRKSRC}/WPrefs.app/Paths.c
@${REINPLACE_CMD} -e "s|%%PERL%%|${PERL}|g" ${WRKSRC}/util/wm-oldmenu2new