aboutsummaryrefslogtreecommitdiffstats
path: root/x11-wm
diff options
context:
space:
mode:
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/swm/Makefile10
1 files changed, 6 insertions, 4 deletions
diff --git a/x11-wm/swm/Makefile b/x11-wm/swm/Makefile
index 5982a4601a46..087fdad8411d 100644
--- a/x11-wm/swm/Makefile
+++ b/x11-wm/swm/Makefile
@@ -34,6 +34,8 @@ SCRIPTS= startswm
DATA= background.xpm closebox.xpm maxbox.xpm stickybox.xpm \
swm.colors unstickybox.xpm
+MAKE_JOBS_UNSAFE= yes
+
post-patch:
@${REINPLACE_CMD} -e 's|monotype|fixed|g ; \
s|/usr/share/swm|${DATADIR}|g' ${WRKSRC}/swm.conf
@@ -45,11 +47,11 @@ post-build:
*.c -o ${WRKSRC}/swmswitch -lX11 -L${LOCALBASE}/lib
do-install:
-.for file in ${BINS}
- ${INSTALL_PROGRAM} ${WRKSRC}/${file} ${STAGEDIR}${PREFIX}/bin
+.for f in ${BINS}
+ ${INSTALL_PROGRAM} ${WRKSRC}/${f} ${STAGEDIR}${PREFIX}/bin
.endfor
-.for file in ${SCRIPTS}
- ${INSTALL_SCRIPT} ${WRKSRC}/${file} ${STAGEDIR}${PREFIX}/bin
+.for f in ${SCRIPTS}
+ ${INSTALL_SCRIPT} ${WRKSRC}/${f} ${STAGEDIR}${PREFIX}/bin
.endfor
${INSTALL_MAN} ${WRKSRC}/swm.1x ${STAGEDIR}${MANPREFIX}/man/man1/swm.1
${INSTALL_MAN} ${WRKSRC}/../swmbg/swmbg.1x ${STAGEDIR}${MANPREFIX}/man/man1/swmbg.1