aboutsummaryrefslogtreecommitdiffstats
path: root/x11/9box
diff options
context:
space:
mode:
Diffstat (limited to 'x11/9box')
-rw-r--r--x11/9box/Makefile8
-rw-r--r--x11/9box/files/patch-src::Makefile4
2 files changed, 5 insertions, 7 deletions
diff --git a/x11/9box/Makefile b/x11/9box/Makefile
index 6e97349b015b..7374d81e40b2 100644
--- a/x11/9box/Makefile
+++ b/x11/9box/Makefile
@@ -7,7 +7,7 @@
PORTNAME= 9box
PORTVERSION= 0.2.1
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= x11
MASTER_SITES= ${MASTER_SITE_LOCAL}
MASTER_SITE_SUBDIR= thierry
@@ -16,15 +16,13 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= 9box can "pack" windows inside itself
PLIST_FILES= bin/9box
-USE_XLIB= yes
-USE_X_PREFIX= yes
USE_GMAKE= yes
-USE_XORG= xbitmaps
+USE_XORG= xbitmaps x11 xt
BUILD_WRKSRC= ${WRKSRC}/src
post-patch:
- @${REINPLACE_CMD} -e 's|%%X11BASE%%|${X11BASE}|g; \
+ @${REINPLACE_CMD} -e 's|%%LOCALBASE%%|${LOCALBASE}|g; \
s|%%CC%%|${CC}|g' \
${WRKSRC}/src/Makefile
diff --git a/x11/9box/files/patch-src::Makefile b/x11/9box/files/patch-src::Makefile
index 68e2c34d4905..654ee9c50f60 100644
--- a/x11/9box/files/patch-src::Makefile
+++ b/x11/9box/files/patch-src::Makefile
@@ -2,8 +2,8 @@
+++ src/Makefile Wed Jul 23 21:35:39 2003
@@ -1,10 +1,14 @@
+CC= %%CC%%
-+CFLAGS+= -g -I. -I%%X11BASE%%/include
-+LIBS+= -L%%X11BASE%%/lib -lX11
++CFLAGS+= -g -I. -I%%LOCALBASE%%/include
++LIBS+= -L%%LOCALBASE%%/lib -lX11
+
all: 9box