aboutsummaryrefslogtreecommitdiffstats
path: root/x11/Terminal/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11/Terminal/Makefile')
-rw-r--r--x11/Terminal/Makefile15
1 files changed, 5 insertions, 10 deletions
diff --git a/x11/Terminal/Makefile b/x11/Terminal/Makefile
index 4262014a8d6c..e06884785aec 100644
--- a/x11/Terminal/Makefile
+++ b/x11/Terminal/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: Terminal
-# Date created: 23 October 2004
-# Whom: Matt Lancereau <ports@FreeBSD.org>
-#
+# Created by: Matt Lancereau <ports@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= Terminal
PORTVERSION= 0.4.8
@@ -29,26 +25,25 @@ USE_XORG= x11
CONFIGURE_ARGS= --without-gnome-default-appsdir
CONFIGURE_ENV+= ac_cv_prog_AWK="${AWK}"
-OPTIONS= DBUS "Enable D-BUS support" on \
- NLS "Enable Native Language Support" on
+OPTIONS_DEFINE= DBUS NLS
MAN1= Terminal.1
MANLANG= "" ca da el es fr gl id it ja pt ru sv ug zh_CN
.include <bsd.port.pre.mk>
-.if defined(NOPORTDOCS)
+.if empty(PORT_OPTIONS:MDOCS)
EXTRA_PATCHES+= ${FILESDIR}/extra-patch-doc-Makefile.in
.endif
-.if !defined(WITHOUT_DBUS)
+.if ${PORT_OPTIONS:MDBUS}
LIB_DEPENDS+= dbus-glib-1.2:${PORTSDIR}/devel/dbus-glib
CONFIGURE_ARGS+=--enable-dbus
.else
CONFIGURE_ARGS+=--disable-dbus
.endif
-.if !defined(WITHOUT_NLS)
+.if ${PORT_OPTIONS:MNLS}
USE_GETTEXT= yes
CONFIGURE_ARGS+=--enable-nls
PLIST_SUB+= NLS=""