aboutsummaryrefslogtreecommitdiffstats
path: root/x11/XFree86-4-manuals/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11/XFree86-4-manuals/Makefile')
-rw-r--r--x11/XFree86-4-manuals/Makefile1008
1 files changed, 10 insertions, 998 deletions
diff --git a/x11/XFree86-4-manuals/Makefile b/x11/XFree86-4-manuals/Makefile
index 4b55dcc4365d..14387eccb4bf 100644
--- a/x11/XFree86-4-manuals/Makefile
+++ b/x11/XFree86-4-manuals/Makefile
@@ -6,1022 +6,34 @@
#
PORTNAME= manuals
-PORTVERSION= 4.0.1
+PORTVERSION= 4.0.3
CATEGORIES= x11
MASTER_SITES= ${MASTER_SITE_XFREE}
MASTER_SITE_SUBDIR= ${PORTVERSION}
PKGNAMEPREFIX= XFree86-
-DISTFILES= X401src-1.tgz
+DISTFILES= X402src-1.tgz
MAINTAINER= taguchi@tohoku.iij.ad.jp
XFREE86_VERSION= 4
USE_IMAKE= YES
+EXTRACT_TARGET= xc/doc/man \
+ xc/extras/ogl-sample/main/doc/man
+EXTRACT_AFTER_ARGS= | ${TAR} -xf - ${EXTRACT_TARGET}
PROJECTROOT= -DProjectRoot=${PREFIX}
DIST_SUBDIR= xc
WRKSRC= ${WRKDIR}/xc/doc/man
INSTALL_TARGET= install.man
-MANCOMPRESSED= yes
-MAN3= AllPlanes.3 \
- BitmapBitOrder.3 \
- BitmapPad.3 \
- BitmapUnit.3 \
- BlackPixel.3 \
- BlackPixelOfScreen.3 \
- CellsOfScreen.3 \
- ClientWhitePointOfCCC.3 \
- ConnectionNumber.3 \
- DBE.3 \
- DefaultColormap.3 \
- DefaultColormapOfScreen.3 \
- DefaultDepth.3 \
- DefaultDepthOfScreen.3 \
- DefaultGC.3 \
- DefaultGCOfScreen.3 \
- DefaultRootWindow.3 \
- DefaultScreen.3 \
- DefaultScreenOfDisplay.3 \
- DefaultVisual.3 \
- DefaultVisualOfScreen.3 \
- DisplayCells.3 \
- DisplayHeight.3 \
- DisplayHeightMM.3 \
- DisplayOfCCC.3 \
- DisplayOfScreen.3 \
- DisplayPlanes.3 \
- DisplayString.3 \
- DisplayWidth.3 \
- DisplayWidthMM.3 \
- DoesBackingStore.3 \
- DoesSaveUnders.3 \
- EventMaskOfScreen.3 \
- HeightMMOfScreen.3 \
- HeightOfScreen.3 \
- ImageByteOrder.3 \
- IsCursorKey.3 \
- IsFunctionKey.3 \
- IsKeypadKey.3 \
- IsMiscFunctionKey.3 \
- IsModiferKey.3 \
- IsPFKey.3 \
- IsPrivateKeypadKey.3 \
- LastKnownRequestProcessed.3 \
- MaxCmapsOfScreen.3 \
- MenuPopdown.3 \
- MenuPopup.3 \
- MinCmapsOfScreen.3 \
- NextRequest.3 \
- PlanesOfScreen.3 \
- ProtocolRevision.3 \
- ProtocolVersion.3 \
- QLength.3 \
- RootWindow.3 \
- RootWindowOfScreen.3 \
- ScreenCount.3 \
- ScreenNumberOfCCC.3 \
- ScreenOfDisplay.3 \
- ScreenWhitePointOfCCC.3 \
- ServerVendor.3 \
- VendorRelease.3 \
- VisualOfCCC.3 \
- WhitePixel.3 \
- WhitePixelOfScreen.3 \
- WidthMMOfScreen.3 \
- WidthOfScreen.3 \
- XActivateScreenSaver.3 \
- XAddConnectionWatch.3 \
- XAddHost.3 \
- XAddHosts.3 \
- XAddPixel.3 \
- XAddToSaveSet.3 \
- XAllocClassHint.3 \
- XAllocColor.3 \
- XAllocColorCells.3 \
- XAllocColorPlanes.3 \
- XAllocIconSize.3 \
- XAllocNamedColor.3 \
- XAllocSizeHints.3 \
- XAllocStandardColormap.3 \
- XAllocWMHints.3 \
- XAllowDeviceEvents.3 \
- XAllowEvents.3 \
- XAnyEvent.3 \
- XArc.3 \
- XAutoRepeatOff.3 \
- XAutoRepeatOn.3 \
- XBaseFontNameListOfFontSet.3 \
- XBell.3 \
- XButtonEvent.3 \
- XChangeActivePointerGrab.3 \
- XChangeDeviceControl.3 \
- XChangeDeviceDontPropagateList.3 \
- XChangeDeviceKeyMapping.3 \
- XChangeFeedbackControl.3 \
- XChangeGC.3 \
- XChangeKeyboardControl.3 \
- XChangeKeyboardDevice.3 \
- XChangeKeyboardMapping.3 \
- XChangePointerControl.3 \
- XChangePointerDevice.3 \
- XChangeProperty.3 \
- XChangeSaveSet.3 \
- XChangeWindowAttributes.3 \
- XChar2b.3 \
- XCharStruct.3 \
- XCheckIfEvent.3 \
- XCheckMaskEvent.3 \
- XCheckTypedEvent.3 \
- XCheckTypedWindowEvent.3 \
- XCheckWindowEvent.3 \
- XCirculateEvent.3 \
- XCirculateRequestEvent.3 \
- XCirculateSubwindows.3 \
- XCirculateSubwindowsDown.3 \
- XCirculateSubwindowsUp.3 \
- XClassHint.3 \
- XClearArea.3 \
- XClearWindow.3 \
- XClientMessageEvent.3 \
- XClipBox.3 \
- XCloseDevice.3 \
- XCloseDisplay.3 \
- XCloseIM.3 \
- XCloseOM.3 \
- XColor.3 \
- XColormapEvent.3 \
- XConfigureEvent.3 \
- XConfigureRequestEvent.3 \
- XConfigureWindow.3 \
- XContextDependentDrawing.3 \
- XContextualDrawing.3 \
- XConvertCase.3 \
- XConvertSelection.3 \
- XCopyArea.3 \
- XCopyColormapAndFree.3 \
- XCopyGC.3 \
- XCopyPlane.3 \
- XCreateBitmapFromData.3 \
- XCreateColormap.3 \
- XCreateFontCursor.3 \
- XCreateFontSet.3 \
- XCreateGC.3 \
- XCreateGlyphCursor.3 \
- XCreateIC.3 \
- XCreateImage.3 \
- XCreateOC.3 \
- XCreatePixmap.3 \
- XCreatePixmapCursor.3 \
- XCreatePixmapFromBitmapData.3 \
- XCreateRegion.3 \
- XCreateSimpleWindow.3 \
- XCreateWindow.3 \
- XCreateWindowEvent.3 \
- XCrossingEvent.3 \
- XDefaultString.3 \
- XDefineCursor.3 \
- XDeleteContext.3 \
- XDeleteModifiermapEntry.3 \
- XDeleteProperty.3 \
- XDestroyIC.3 \
- XDestroyImage.3 \
- XDestroyOC.3 \
- XDestroyRegion.3 \
- XDestroySubwindows.3 \
- XDestroyWindow.3 \
- XDestroyWindowEvent.3 \
- XDeviceBell.3 \
- XDeviceTimeCoord.3 \
- XDirectionalDependentDrawing.3 \
- XDisableAccessControl.3 \
- XDisplayKeycodes.3 \
- XDisplayMotionBufferSize.3 \
- XDisplayName.3 \
- XDisplayOfIM.3 \
- XDisplayOfOM.3 \
- XDrawArc.3 \
- XDrawArcs.3 \
- XDrawImageString.3 \
- XDrawImageString16.3 \
- XDrawLine.3 \
- XDrawLines.3 \
- XDrawPoint.3 \
- XDrawPoints.3 \
- XDrawRectangle.3 \
- XDrawRectangles.3 \
- XDrawSegments.3 \
- XDrawString.3 \
- XDrawString16.3 \
- XDrawText.3 \
- XDrawText16.3 \
- XEmptyRegion.3 \
- XEnableAccessControl.3 \
- XEqualRegion.3 \
- XErrorEvent.3 \
- XEvent.3 \
- XEventsQueued.3 \
- XExposeEvent.3 \
- XExtendedMaxRequestSize.3 \
- XExtentsOfFontSet.3 \
- XFetchBuffer.3 \
- XFetchBytes.3 \
- XFetchName.3 \
- XFillArc.3 \
- XFillArcs.3 \
- XFillPolygon.3 \
- XFillRectangle.3 \
- XFillRectangles.3 \
- XFilterEvent.3 \
- XFindContext.3 \
- XFlush.3 \
- XFocusChangeEvent.3 \
- XFontProp.3 \
- XFontSetExtents.3 \
- XFontStruct.3 \
- XFontsOfFontSet.3 \
- XForceScreenSaver.3 \
- XFree.3 \
- XFreeColormap.3 \
- XFreeColors.3 \
- XFreeCursor.3 \
- XFreeDeviceList.3 \
- XFreeFont.3 \
- XFreeFontInfo.3 \
- XFreeFontNames.3 \
- XFreeFontPath.3 \
- XFreeFontSet.3 \
- XFreeGC.3 \
- XFreeModifierMap.3 \
- XFreePixmap.3 \
- XFreeStringList.3 \
- XGCValues.3 \
- XGContextFromGC.3 \
- XGetAtomName.3 \
- XGetAtomNames.3 \
- XGetClassHint.3 \
- XGetCommand.3 \
- XGetDeviceButtonMapping.3 \
- XGetDeviceControl.3 \
- XGetDeviceDontPropagateList.3 \
- XGetDeviceFocus.3 \
- XGetDeviceKeyMapping.3 \
- XGetDeviceModifierMapping.3 \
- XGetDeviceMotionEvents.3 \
- XGetErrorDatabaseText.3 \
- XGetErrorText.3 \
- XGetExtensionVersion.3 \
- XGetFeedbackControl.3 \
- XGetFontPath.3 \
- XGetFontProperty.3 \
- XGetGCValues.3 \
- XGetGeometry.3 \
- XGetICValues.3 \
- XGetIMValues.3 \
- XGetIconName.3 \
- XGetIconSizes.3 \
- XGetImage.3 \
- XGetInputFocus.3 \
- XGetKeyboardControl.3 \
- XGetKeyboardMapping.3 \
- XGetModifierMapping.3 \
- XGetMotionEvents.3 \
- XGetOCValues.3 \
- XGetOMValues.3 \
- XGetPixel.3 \
- XGetPointerControl.3 \
- XGetPointerMapping.3 \
- XGetRGBColormaps.3 \
- XGetScreenSaver.3 \
- XGetSelectedExtensionEvents.3 \
- XGetSelectionOwner.3 \
- XGetSubImage.3 \
- XGetTextProperty.3 \
- XGetTransientForHint.3 \
- XGetVisualInfo.3 \
- XGetWMClientMachine.3 \
- XGetWMColormapWindows.3 \
- XGetWMHints.3 \
- XGetWMIconName.3 \
- XGetWMName.3 \
- XGetWMNormalHints.3 \
- XGetWMProtocols.3 \
- XGetWMSizeHints.3 \
- XGetWindowAttributes.3 \
- XGetWindowProperty.3 \
- XGrabButton.3 \
- XGrabDevice.3 \
- XGrabDeviceButton.3 \
- XGrabDeviceKey.3 \
- XGrabKey.3 \
- XGrabKeyboard.3 \
- XGrabPointer.3 \
- XGrabServer.3 \
- XGraphicsExposeEvent.3 \
- XGravityEvent.3 \
- XHostAddress.3 \
- XIMOfIC.3 \
- XIconSize.3 \
- XIconifyWindow.3 \
- XIfEvent.3 \
- XInitImage.3 \
- XInitThreads.3 \
- XInsertModifiermapEntry.3 \
- XInstallColormap.3 \
- XInternAtom.3 \
- XInternAtoms.3 \
- XInternalConnectionNumbers.3 \
- XIntersectRegion.3 \
- XKeyEvent.3 \
- XKeyboardControl.3 \
- XKeycodeToKeysym.3 \
- XKeymapEvent.3 \
- XKeysymToKeycode.3 \
- XKeysymToString.3 \
- XKillClient.3 \
- XListDepths.3 \
- XListFonts.3 \
- XListFontsWithInfo.3 \
- XListHosts.3 \
- XListInputDevices.3 \
- XListInstalledColormaps.3 \
- XListPixmapFormats.3 \
- XListProperties.3 \
- XLoadFont.3 \
- XLoadQueryFont.3 \
- XLocaleOfFontSet.3 \
- XLocaleOfIM.3 \
- XLocaleOfOM.3 \
- XLockDisplay.3 \
- XLookupColor.3 \
- XLookupKeysym.3 \
- XLookupString.3 \
- XLowerWindow.3 \
- XMapEvent.3 \
- XMapRaised.3 \
- XMapRequestEvent.3 \
- XMapSubwindows.3 \
- XMapWindow.3 \
- XMappingEvent.3 \
- XMaskEvent.3 \
- XMatchVisualInfo.3 \
- XMaxRequestSize.3 \
- XModifierKeymap.3 \
- XMotionEvent.3 \
- XMoveResizeWindow.3 \
- XMoveWindow.3 \
- XNewModifiermap.3 \
- XNextEvent.3 \
- XNoExposeEvent.3 \
- XNoOp.3 \
- XOMOfOC.3 \
- XOffsetRegion.3 \
- XOpenDevice.3 \
- XOpenDisplay.3 \
- XOpenIM.3 \
- XOpenOM.3 \
- XParseColor.3 \
- XParseGeometry.3 \
- XPeekEvent.3 \
- XPeekIfEvent.3 \
- XPending.3 \
- XPixmapFormatValues.3 \
- XPoint.3 \
- XPointInRegion.3 \
- XPolygonRegion.3 \
- XProcessInternalConnection.3 \
- XPropertyEvent.3 \
- XPutBackEvent.3 \
- XPutImage.3 \
- XPutPixel.3 \
- XQueryBestCursor.3 \
- XQueryBestSize.3 \
- XQueryBestStipple.3 \
- XQueryBestTile.3 \
- XQueryColor.3 \
- XQueryColors.3 \
- XQueryDeviceState.3 \
- XQueryFont.3 \
- XQueryKeymap.3 \
- XQueryPointer.3 \
- XQueryTextExtents.3 \
- XQueryTextExtents16.3 \
- XQueryTree.3 \
- XRaiseWindow.3 \
- XReadBitmapFile.3 \
- XReadBitmapFileData.3 \
- XRebindKeySym.3 \
- XRecolorCursor.3 \
- XReconfigureWMWindow.3 \
- XRectInRegion.3 \
- XRectangle.3 \
- XRefreshKeyboardMapping.3 \
- XRegisterIMInstantiateCallback.3 \
- XRemoveConnectionWatch.3 \
- XRemoveFromSaveSet.3 \
- XRemoveHost.3 \
- XRemoveHosts.3 \
- XReparentEvent.3 \
- XReparentWindow.3 \
- XResetScreenSaver.3 \
- XResizeRequestEvent.3 \
- XResizeWindow.3 \
- XResourceManagerString.3 \
- XRestackWindows.3 \
- XRotateBuffers.3 \
- XRotateWindowProperties.3 \
- XSaveContext.3 \
- XScreenNumberOfScreen.3 \
- XScreenResourceString.3 \
- XSegment.3 \
- XSelectExtensionEvent.3 \
- XSelectInput.3 \
- XSelectionClearEvent.3 \
- XSelectionEvent.3 \
- XSelectionRequestEvent.3 \
- XSendEvent.3 \
- XSendExtensionEvent.3 \
- XSetAccessControl.3 \
- XSetAfterFunction.3 \
- XSetArcMode.3 \
- XSetBackground.3 \
- XSetClassHint.3 \
- XSetClipMask.3 \
- XSetClipOrigin.3 \
- XSetClipRectangles.3 \
- XSetCloseDownMode.3 \
- XSetCommand.3 \
- XSetDashes.3 \
- XSetDeviceButtonMapping.3 \
- XSetDeviceFocus.3 \
- XSetDeviceMode.3 \
- XSetDeviceModifierMapping.3 \
- XSetDeviceValuators.3 \
- XSetErrorHandler.3 \
- XSetFillRule.3 \
- XSetFillStyle.3 \
- XSetFont.3 \
- XSetFontPath.3 \
- XSetForeground.3 \
- XSetFunction.3 \
- XSetGraphicsExposure.3 \
- XSetICFocus.3 \
- XSetICValues.3 \
- XSetIMValues.3 \
- XSetIOErrorHandler.3 \
- XSetIconName.3 \
- XSetIconSizes.3 \
- XSetInputFocus.3 \
- XSetLineAttributes.3 \
- XSetLocaleModifiers.3 \
- XSetModifierMapping.3 \
- XSetOCValues.3 \
- XSetOMValues.3 \
- XSetPlanemask.3 \
- XSetPointerMapping.3 \
- XSetRGBColormaps.3 \
- XSetRegion.3 \
- XSetScreenSaver.3 \
- XSetSelectionOwner.3 \
- XSetState.3 \
- XSetStipple.3 \
- XSetSubwindowMode.3 \
- XSetTSOrigin.3 \
- XSetTextProperty.3 \
- XSetTile.3 \
- XSetTransientForHint.3 \
- XSetWMClientMachine.3 \
- XSetWMColormapWindows.3 \
- XSetWMHints.3 \
- XSetWMIconName.3 \
- XSetWMName.3 \
- XSetWMNormalHints.3 \
- XSetWMProperties.3 \
- XSetWMProtocols.3 \
- XSetWMSizeHints.3 \
- XSetWindowAttributes.3 \
- XSetWindowBackground.3 \
- XSetWindowBackgroundPixmap.3 \
- XSetWindowBorder.3 \
- XSetWindowBorderPixmap.3 \
- XSetWindowBorderWidth.3 \
- XSetWindowColormap.3 \
- XShapeCombineMask.3 \
- XShapeCombineRectangles.3 \
- XShapeCombineRegion.3 \
- XShapeCombineShape.3 \
- XShapeGetRectangles.3 \
- XShapeInputSelected.3 \
- XShapeOffsetShape.3 \
- XShapeQueryExtension.3 \
- XShapeQueryExtents.3 \
- XShapeQueryVersion.3 \
- XShapeSelectInput.3 \
- XShrinkRegion.3 \
- XSizeHints.3 \
- XStandardColormap.3 \
- XStoreBuffer.3 \
- XStoreBytes.3 \
- XStoreColor.3 \
- XStoreColors.3 \
- XStoreName.3 \
- XStoreNamedColor.3 \
- XStringListToTextProperty.3 \
- XStringToKeysym.3 \
- XSubImage.3 \
- XSubtractRegion.3 \
- XSupportsLocale.3 \
- XSync.3 \
- XSynchronize.3 \
- XTextExtents.3 \
- XTextExtents16.3 \
- XTextItem.3 \
- XTextItem16.3 \
- XTextProperty.3 \
- XTextPropertyToStringList.3 \
- XTextWidth.3 \
- XTextWidth16.3 \
- XTimeCoord.3 \
- XTranslateCoordinates.3 \
- XUndefineCursor.3 \
- XUngrabButton.3 \
- XUngrabDevice.3 \
- XUngrabDeviceButton.3 \
- XUngrabDeviceKey.3 \
- XUngrabKey.3 \
- XUngrabKeyboard.3 \
- XUngrabPointer.3 \
- XUngrabServer.3 \
- XUninstallColormap.3 \
- XUnionRectWithRegion.3 \
- XUnionRegion.3 \
- XUniqueContext.3 \
- XUnloadFont.3 \
- XUnlockDisplay.3 \
- XUnmapEvent.3 \
- XUnmapSubwindows.3 \
- XUnmapWindow.3 \
- XUnregisterIMInstantiateCallback.3 \
- XUnsetICFocus.3 \
- XVaCreateNestedList.3 \
- XVisibilityNotifyEvent.3 \
- XVisualIDFromVisual.3 \
- XVisualInfo.3 \
- XWMGeometry.3 \
- XWMHints.3 \
- XWarpPointer.3 \
- XWindowAttributes.3 \
- XWindowChanges.3 \
- XWindowEvent.3 \
- XWithdrawWindow.3 \
- XWriteBitmapFile.3 \
- XXorRegion.3 \
- Xau.3 \
- XauDisposeAuth.3 \
- XauFileName.3 \
- XauGetAuthByAddr.3 \
- XauGetBestAuthByAddr.3 \
- XauLockAuth.3 \
- XauReadAuth.3 \
- XauUnlockAuth.3 \
- XauWriteAuth.3 \
- XcmsAllocColor.3 \
- XcmsAllocNamedColor.3 \
- XcmsCCCOfColormap.3 \
- XcmsCIELab.3 \
- XcmsCIELabQueryMaxC.3 \
- XcmsCIELabQueryMaxL.3 \
- XcmsCIELabQueryMaxLC.3 \
- XcmsCIELabQueryMinL.3 \
- XcmsCIELuv.3 \
- XcmsCIELuvQueryMaxC.3 \
- XcmsCIELuvQueryMaxL.3 \
- XcmsCIELuvQueryMaxLC.3 \
- XcmsCIELuvQueryMinL.3 \
- XcmsCIEXYZ.3 \
- XcmsCIEuvY.3 \
- XcmsCIExyY.3 \
- XcmsColor.3 \
- XcmsConvertColors.3 \
- XcmsCreateCCC.3 \
- XcmsDefaultCCC.3 \
- XcmsFreeCCC.3 \
- XcmsLookupColor.3 \
- XcmsPad.3 \
- XcmsQueryBlack.3 \
- XcmsQueryBlue.3 \
- XcmsQueryColor.3 \
- XcmsQueryColors.3 \
- XcmsQueryGreen.3 \
- XcmsQueryRed.3 \
- XcmsQueryWhite.3 \
- XcmsRGB.3 \
- XcmsRGBi.3 \
- XcmsSetCCCOfColormap.3 \
- XcmsSetWhiteAdjustProc.3 \
- XcmsSetWhitePoint.3 \
- XcmsStoreColor.3 \
- XcmsStoreColors.3 \
- XcmsTekHVC.3 \
- XcmsTekHVCQueryMaxC.3 \
- XcmsTekHVCQueryMaxV.3 \
- XcmsTekHVCQueryMaxVC.3 \
- XcmsTekHVCQueryMaxVSamples.3 \
- XcmsTekHVCQueryMinV.3 \
- XdbeAllocateBackBufferName.3 \
- XdbeBeginIdiom.3 \
- XdbeDeallocateBackBufferName.3 \
- XdbeEndIdiom.3 \
- XdbeFreeVisualInfo.3 \
- XdbeGetBackBufferAttributes.3 \
- XdbeGetVisualInfo.3 \
- XdbeQueryExtension.3 \
- XdbeSwapBuffers.3 \
- XeviGetVisualInfo.3 \
- XeviQueryVersion.3 \
- XmbDrawImageString.3 \
- XmbDrawString.3 \
- XmbDrawText.3 \
- XmbLookupString.3 \
- XmbResetIC.3 \
- XmbSetWMProperties.3 \
- XmbTextEscapement.3 \
- XmbTextExtents.3 \
- XmbTextListToTextProperty.3 \
- XmbTextPerCharExtents.3 \
- XmbTextPropertyToTextList.3 \
- XmbufChangeBufferAttributes.3 \
- XmbufChangeWindowAttributes.3 \
- XmbufCreateBuffers.3 \
- XmbufCreateStereoWindow.3 \
- XmbufDestroyBuffers.3 \
- XmbufDisplayBuffers.3 \
- XmbufGetBufferAttributes.3 \
- XmbufGetScreenInfo.3 \
- XmbufGetVersion.3 \
- XmbufGetWindowAttributes.3 \
- XmbufQueryExtension.3 \
- XrmCombineDatabase.3 \
- XrmCombineFileDatabase.3 \
- XrmDestroyDatabase.3 \
- XrmEnumerateDatabase.3 \
- XrmGetDatabase.3 \
- XrmGetFileDatabase.3 \
- XrmGetResource.3 \
- XrmGetStringDatabase.3 \
- XrmInitialize.3 \
- XrmLocaleOfDatabase.3 \
- XrmMergeDatabases.3 \
- XrmOptionDescRec.3 \
- XrmOptionKind.3 \
- XrmParseCommand.3 \
- XrmPermStringToQuark.3 \
- XrmPutFileDatabase.3 \
- XrmPutLineResource.3 \
- XrmPutResource.3 \
- XrmPutStringResource.3 \
- XrmQGetResource.3 \
- XrmQGetSearchList.3 \
- XrmQGetSearchResource.3 \
- XrmQPutResource.3 \
- XrmQPutStringResource.3 \
- XrmQuarkToString.3 \
- XrmSetDatabase.3 \
- XrmStringToBindingQuarkList.3 \
- XrmStringToQuark.3 \
- XrmStringToQuarkList.3 \
- XrmUniqueQuark.3 \
- XrmValue.3 \
- XtAddActions.3 \
- XtAddCallback.3 \
- XtAddCallbacks.3 \
- XtAddConverter.3 \
- XtAddEventHandler.3 \
- XtAddExposureToRegion.3 \
- XtAddGrab.3 \
- XtAddInput.3 \
- XtAddRawEventHandler.3 \
- XtAddTimeOut.3 \
- XtAddTimeout.3 \
- XtAllocateGC.3 \
- XtAppAddActionHook.3 \
- XtAppAddActions.3 \
- XtAppAddBlockHook.3 \
- XtAppAddConverter.3 \
- XtAppAddInput.3 \
- XtAppAddSignal.3 \
- XtAppAddTimeOut.3 \
- XtAppAddTimeout.3 \
- XtAppAddWorkProc.3 \
- XtAppCreateShell.3 \
- XtAppError.3 \
- XtAppErrorMsg.3 \
- XtAppGetErrorDatabase.3 \
- XtAppGetErrorDatabaseText.3 \
- XtAppGetExitFlag.3 \
- XtAppGetSelectionTimeout.3 \
- XtAppInitialize.3 \
- XtAppLock.3 \
- XtAppMainLoop.3 \
- XtAppNextEvent.3 \
- XtAppPeekEvent.3 \
- XtAppPending.3 \
- XtAppProcessEvent.3 \
- XtAppReleaseCacheRefs.3 \
- XtAppSetErrorHandler.3 \
- XtAppSetErrorMsgHandler.3 \
- XtAppSetExitFlag.3 \
- XtAppSetFallbackResources.3 \
- XtAppSetSelectionTimeout.3 \
- XtAppSetTypeConverter.3 \
- XtAppSetWarningHandler.3 \
- XtAppSetWarningMsgHandler.3 \
- XtAppUnlock.3 \
- XtAppWarning.3 \
- XtAppWarningMsg.3 \
- XtAugmentTranslations.3 \
- XtBuildEventMask.3 \
- XtCallAcceptFocus.3 \
- XtCallActionProc.3 \
- XtCallCallbackList.3 \
- XtCallCallbacks.3 \
- XtCallConverter.3 \
- XtCallbackExclusive.3 \
- XtCallbackNone.3 \
- XtCallbackNonexclusive.3 \
- XtCallbackPopdown.3 \
- XtCalloc.3 \
- XtCancelSelectionRequest.3 \
- XtChangeManagedSet.3 \
- XtCheckSubclass.3 \
- XtClass.3 \
- XtCloseDisplay.3 \
- XtConfigureWidget.3 \
- XtConvert.3 \
- XtConvertAndStore.3 \
- XtConvertCase.3 \
- XtCreateApplicationContext.3 \
- XtCreateApplicationShell.3 \
- XtCreateManagedWidget.3 \
- XtCreatePopupShell.3 \
- XtCreateSelectionRequest.3 \
- XtCreateWidget.3 \
- XtCreateWindow.3 \
- XtDatabase.3 \
- XtDestroyApplicationContext.3 \
- XtDestroyWidget.3 \
- XtDirectConvert.3 \
- XtDisownSelection.3 \
- XtDispatchEvent.3 \
- XtDispatchEventToWidget.3 \
- XtDisplay.3 \
- XtDisplayInitialize.3 \
- XtDisplayOfObject.3 \
- XtDisplayStringConversionWarning.3 \
- XtDisplayToApplicationContext.3 \
- XtError.3 \
- XtErrorMsg.3 \
- XtFindFile.3 \
- XtFree.3 \
- XtGetActionKeysym.3 \
- XtGetActionList.3 \
- XtGetApplicationNameAndClass.3 \
- XtGetApplicationResources.3 \
- XtGetClassExtension.3 \
- XtGetConstraintResourceList.3 \
- XtGetDisplays.3 \
- XtGetErrorDatabase.3 \
- XtGetErrorDatabaseText.3 \
- XtGetGC.3 \
- XtGetKeyboardFocusWidget.3 \
- XtGetKeysymTable.3 \
- XtGetMultiClickTime.3 \
- XtGetResourceList.3 \
- XtGetSelectionParameters.3 \
- XtGetSelectionRequest.3 \
- XtGetSelectionTimeout.3 \
- XtGetSelectionValue.3 \
- XtGetSelectionValueIncremental.3 \
- XtGetSelectionValues.3 \
- XtGetSelectionValuesIncremental.3 \
- XtGetSubresources.3 \
- XtGetSubvalues.3 \
- XtGetValues.3 \
- XtGrabButton.3 \
- XtGrabKey.3 \
- XtGrabKeyboard.3 \
- XtGrabPointer.3 \
- XtHasCallbacks.3 \
- XtHooksOfDisplay.3 \
- XtInitialize.3 \
- XtInitializeWidgetClass.3 \
- XtInsertEventHandler.3 \
- XtInsertEventTypeHandler.3 \
- XtInsertRawEventHandler.3 \
- XtInstallAccelerators.3 \
- XtInstallAllAccelerators.3 \
- XtIsApplicationShell.3 \
- XtIsComposite.3 \
- XtIsConstraint.3 \
- XtIsManaged.3 \
- XtIsObject.3 \
- XtIsOverrideShell.3 \
- XtIsRealized.3 \
- XtIsRectObj.3 \
- XtIsSensitive.3 \
- XtIsShell.3 \
- XtIsSubclass.3 \
- XtIsTopLevelShell.3 \
- XtIsTransientShell.3 \
- XtIsVendorShell.3 \
- XtIsWMShell.3 \
- XtIsWidget.3 \
- XtKeysymToKeycodeList.3 \
- XtLastEventProcessed.3 \
- XtLastTimestampProcessed.3 \
- XtMainLoop.3 \
- XtMakeGeometryRequest.3 \
- XtMakeResizeRequest.3 \
- XtMalloc.3 \
- XtManageChild.3 \
- XtManageChildren.3 \
- XtMapWidget.3 \
- XtMergeArgLists.3 \
- XtMoveWidget.3 \
- XtName.3 \
- XtNameToWidget.3 \
- XtNew.3 \
- XtNewString.3 \
- XtNextEvent.3 \
- XtNoticeSignal.3 \
- XtNumber.3 \
- XtOffset.3 \
- XtOffsetOf.3 \
- XtOpenApplication.3 \
- XtOpenDisplay.3 \
- XtOverrideTranslations.3 \
- XtOwnSelection.3 \
- XtOwnSelectionIncremental.3 \
- XtParent.3 \
- XtParseAcceleratorTable.3 \
- XtParseTranslationTable.3 \
- XtPeekEvent.3 \
- XtPending.3 \
- XtPopdown.3 \
- XtPopup.3 \
- XtPopupSpringLoaded.3 \
- XtProcessEvent.3 \
- XtProcessLock.3 \
- XtProcessUnlock.3 \
- XtQueryGeometry.3 \
- XtRealizeWidget.3 \
- XtRealloc.3 \
- XtRegisterCaseConverter.3 \
- XtRegisterDrawable.3 \
- XtRegisterExtensionSelector.3 \
- XtRegisterGrabAction.3 \
- XtReleaseGC.3 \
- XtReleasePropertyAtom.3 \
- XtRemoveActionHook.3 \
- XtRemoveAllCallbacks.3 \
- XtRemoveBlockHook.3 \
- XtRemoveCallback.3 \
- XtRemoveCallbacks.3 \
- XtRemoveEventHandler.3 \
- XtRemoveEventTypeHandler.3 \
- XtRemoveGrab.3 \
- XtRemoveInput.3 \
- XtRemoveRawEventHandler.3 \
- XtRemoveSignal.3 \
- XtRemoveTimeOut.3 \
- XtRemoveWorkProc.3 \
- XtReservePropertyAtom.3 \
- XtResizeWidget.3 \
- XtResolvePathname.3 \
- XtScreen.3 \
- XtScreenDatabase.3 \
- XtScreenOfObject.3 \
- XtSendSelectionRequest.3 \
- XtSessionGetToken.3 \
- XtSessionReturnToken.3 \
- XtSetArg.3 \
- XtSetErrorHandler.3 \
- XtSetErrorMsgHandler.3 \
- XtSetEventDispatcher.3 \
- XtSetKeyTranslator.3 \
- XtSetKeyboardFocus.3 \
- XtSetLanguageProc.3 \
- XtSetMappedWhenManaged.3 \
- XtSetMultiClickTime.3 \
- XtSetSelectionParameters.3 \
- XtSetSelectionTimeout.3 \
- XtSetSensitive.3 \
- XtSetSubvalues.3 \
- XtSetTypeConverter.3 \
- XtSetValues.3 \
- XtSetWMColormapWindows.3 \
- XtSetWarningHandler.3 \
- XtSetWarningMsgHandler.3 \
- XtStringConversionWarning.3 \
- XtSuperclass.3 \
- XtToolkitInitialize.3 \
- XtToolkitThreadInitialize.3 \
- XtTranslateCoords.3 \
- XtTranslateKeycode.3 \
- XtUngrabButton.3 \
- XtUngrabKey.3 \
- XtUngrabKeyboard.3 \
- XtUngrabPointer.3 \
- XtUninstallTranslations.3 \
- XtUnmanageChild.3 \
- XtUnmanageChildren.3 \
- XtUnmapWidget.3 \
- XtUnrealizeWidget.3 \
- XtUnregisterDrawable.3 \
- XtVaAppCreateShell.3 \
- XtVaAppInitialize.3 \
- XtVaCreateArgsList.3 \
- XtVaCreateManagedWidget.3 \
- XtVaCreatePopupShell.3 \
- XtVaCreateWidget.3 \
- XtVaGetApplicationResources.3 \
- XtVaGetSubresources.3 \
- XtVaGetValues.3 \
- XtVaOpenApplication.3 \
- XtVaSetValues.3 \
- XtWarning.3 \
- XtWarningMsg.3 \
- XtWidgetToApplicationContext.3 \
- XtWindow.3 \
- XtWindowOfObject.3 \
- XtWindowToWidget.3 \
- Xv.3 \
- XvFreeAdaptorInfo.3 \
- XvFreeEncodingInfo.3 \
- XvGetPortAttribute.3 \
- XvGetStill.3 \
- XvGetVideo.3 \
- XvGrabPort.3 \
- XvPortNotify.3 \
- XvPutStill.3 \
- XvPutVideo.3 \
- XvQueryAdaptors.3 \
- XvQueryBestSize.3 \
- XvQueryEncodings.3 \
- XvQueryExtension.3 \
- XvSelectPortNotify.3 \
- XvSelectVideoNotify.3 \
- XvSetPortAttribute.3 \
- XvStopVideo.3 \
- XvUngrabPort.3 \
- XvVideoNotify.3 \
- XwcDrawImageString.3 \
- XwcDrawString.3 \
- XwcDrawText.3 \
- XwcFreeStringList.3 \
- XwcLookupString.3 \
- XwcResetIC.3 \
- XwcTextEscapement.3 \
- XwcTextExtents.3 \
- XwcTextListToTextProperty.3 \
- XwcTextPerCharExtents.3 \
- XwcTextPropertyToTextList.3 \
- glXChooseVisual.3 \
- glXCopyContext.3 \
- glXCreateContext.3 \
- glXCreateGLXPixmap.3 \
- glXDestroyContext.3 \
- glXDestroyGLXPixmap.3 \
- glXFreeContextEXT.3 \
- glXGetClientString.3 \
- glXGetConfig.3 \
- glXGetContextIDEXT.3 \
- glXGetCurrentContext.3 \
- glXGetCurrentDisplay.3 \
- glXGetCurrentDrawable.3 \
- glXImportContextEXT.3 \
- glXIntro.3 \
- glXIsDirect.3 \
- glXMakeCurrent.3 \
- glXQueryContextInfoEXT.3 \
- glXQueryExtension.3 \
- glXQueryExtensionsString.3 \
- glXQueryServerString.3 \
- glXQueryVersion.3 \
- glXSwapBuffers.3 \
- glXUseXFont.3 \
- glXWaitGL.3 \
- glXWaitX.3
-MAN7= X.7 \
- XConsortium.7 \
- XProjectTeam.7 \
- XStandards.7 \
- Xsecurity.7
+
+.include <bsd.port.pre.mk>
+.include <${FILESDIR}/manpages>
do-configure:
(cd ${WRKSRC} && \
imake -DUseInstalled ${PROJECTROOT} -I${PREFIX}/lib/X11/config \
- -DTOPDIR=../../.. -DCURDIR=.; \
+ -DTOPDIR=../.. -DCURDIR=.; \
${MAKE} Makefiles ; \
${MAKE} includes ; \
${MAKE} depend)
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>