aboutsummaryrefslogtreecommitdiffstats
path: root/x11/arandr/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11/arandr/Makefile')
-rw-r--r--x11/arandr/Makefile16
1 files changed, 4 insertions, 12 deletions
diff --git a/x11/arandr/Makefile b/x11/arandr/Makefile
index 280c07454424..6c3281a0d5b7 100644
--- a/x11/arandr/Makefile
+++ b/x11/arandr/Makefile
@@ -3,6 +3,7 @@
PORTNAME= arandr
PORTVERSION= 0.1.7.1
+PORTREVISION= 1
CATEGORIES= x11 deskutils
MASTER_SITES= http://christian.amsuess.com/tools/arandr/files/ \
LOCAL/${MAINTAINER:C/([^@]*)@.*/\1/}
@@ -14,31 +15,22 @@ LICENSE= GPLv3
BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}docutils>0.6:${PORTSDIR}/textproc/py-docutils
RUN_DEPENDS= xrandr>0:${PORTSDIR}/x11/xrandr \
- ${PYTHON_PKGNAMEPREFIX}gtk>0:${PORTSDIR}/x11-toolkits/py-gtk2
+ ${PYTHON_PKGNAMEPREFIX}gtk2>0:${PORTSDIR}/x11-toolkits/py-gtk2
OPTIONS_DEFINE= DOCS
USE_PYTHON= yes
USE_PYDISTUTILS= yes
-NO_STAGE= yes
-.include <bsd.port.options.mk>
-
USES+= gettext desktop-file-utils
-MANCOMPRESSED= yes
-MAN1= ${PORTNAME}.1 \
- ${PORTNAME:C/a/unx/}.1
-
PORTDOCS= ChangeLog NEWS README TODO
post-patch:
${REINPLACE_CMD} -i '' 's#share/man#man#' ${WRKSRC}/${PYSETUP}
post-install:
-.if ${PORT_OPTIONS:MDOCS}
- @${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/,} ${DOCSDIR}
-.endif
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/,} ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>