aboutsummaryrefslogtreecommitdiffstats
path: root/x11/dgs/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11/dgs/Makefile')
-rw-r--r--x11/dgs/Makefile9
1 files changed, 7 insertions, 2 deletions
diff --git a/x11/dgs/Makefile b/x11/dgs/Makefile
index 4a605488d72e..a235202eb580 100644
--- a/x11/dgs/Makefile
+++ b/x11/dgs/Makefile
@@ -7,7 +7,7 @@
PORTNAME= dgs
PORTVERSION= 0.5.9.1
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= x11
MASTER_SITES= ${MASTER_SITE_GNU}
MASTER_SITE_SUBDIR= dgs
@@ -25,6 +25,7 @@ USE_GMAKE= yes
USE_GNOME= glib12
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
+USE_AUTOTOOLS= libtool:15
WRKSRC= ${WRKDIR}/${PORTNAME}-0.5.9
MAN1= dgs.1 dpsnx.agent.1
@@ -45,9 +46,13 @@ pre-patch:
@${FIND} ${WRKSRC} -name "Makefile.in" | ${XARGS} \
${REINPLACE_CMD} -e 's|manm|mann|g'
+post-patch:
+ ${REINPLACE_CMD} -e 's|echo aout|echo elf|' \
+ ${WRKSRC}/DPS/ltconfig
+
.if ${X_WINDOW_SYSTEM:L} == xorg
INSTALLDIRS+= DPS/clients/makepsres DPS/clients/pswrap DPS/demos/texteroids \
- DPS/lib/dpstk
+ DPS/lib/dpstk DPS/lib/psres
MANN+= makepsres.man
PLIST_SUB+= WITH_XFREE4=""
.else