aboutsummaryrefslogtreecommitdiffstats
path: root/x11/dmenu/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11/dmenu/Makefile')
-rw-r--r--x11/dmenu/Makefile18
1 files changed, 14 insertions, 4 deletions
diff --git a/x11/dmenu/Makefile b/x11/dmenu/Makefile
index a475dce30f5d..30c021294a33 100644
--- a/x11/dmenu/Makefile
+++ b/x11/dmenu/Makefile
@@ -6,23 +6,28 @@
#
PORTNAME= dmenu
-PORTVERSION= 4.4.1
+PORTVERSION= 4.5
CATEGORIES= x11
MASTER_SITES= http://dl.suckless.org/tools/ \
http://schot.a-eskwadraat.nl/files/
+PATCH_SITES= http://tools.suckless.org/dmenu/patches/ \
+ http://schot.a-eskwadraat.nl/files/
+PATCH_DIST_STRIP=-p1
+
MAINTAINER= schot@a-eskwadraat.nl
COMMENT= X11 menu application designed for the dwm window manager
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE
-OPTIONS= XINERAMA "Enable Xinerama support" On
+OPTIONS= XINERAMA "Enable Xinerama support" On \
+ XFT "Enable Xft support" Off
USE_XORG= x11
-MAN1= dmenu.1 lsx.1
-PLIST_FILES= bin/dmenu bin/dmenu_run bin/lsx
+MAN1= dmenu.1 stest.1
+PLIST_FILES= bin/dmenu bin/dmenu_run bin/stest
.include <bsd.port.options.mk>
@@ -30,6 +35,11 @@ PLIST_FILES= bin/dmenu bin/dmenu_run bin/lsx
USE_XORG+= xinerama
.endif
+.if defined(WITH_XFT)
+USE_XORG+= xft
+PATCHFILES+= ${PORTNAME}-${PORTVERSION}-xft.diff
+.endif
+
post-patch:
@${GREP} -Rl '%%[[:alpha:]]\+%%' ${WRKSRC}|${XARGS} ${REINPLACE_CMD} \
-e "s,%%PREFIX%%,${PREFIX},g" \