aboutsummaryrefslogtreecommitdiffstats
path: root/x11/fbdesk/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11/fbdesk/Makefile')
-rw-r--r--x11/fbdesk/Makefile18
1 files changed, 4 insertions, 14 deletions
diff --git a/x11/fbdesk/Makefile b/x11/fbdesk/Makefile
index bf8b4a57f76c..e0a3b7fa4285 100644
--- a/x11/fbdesk/Makefile
+++ b/x11/fbdesk/Makefile
@@ -13,10 +13,8 @@ COMMENT= Fluxbox utility to create and manage icons on the desktop
LICENSE= MIT
-LIB_DEPENDS= libpng.so:${PORTSDIR}/graphics/png
-
-OPTIONS_DEFINE= IMLIB2 DOCS
-OPTIONS_DEFAULT= IMLIB2
+LIB_DEPENDS= libpng.so:${PORTSDIR}/graphics/png \
+ libImlib2.so:${PORTSDIR}/graphics/imlib2
USE_XORG= xext xft xpm xrender
USES= pkgconfig
@@ -25,18 +23,10 @@ GNU_CONFIGURE= yes
PORTDOCS= ChangeLog INSTALL README
PLIST_FILES= bin/fbdesk
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MIMLIB2}
-LIB_DEPENDS+= libImlib2.so:${PORTSDIR}/graphics/imlib2
-.else
-CONFIGURE_ARGS+= --disable-imlib2
-.endif
+OPTIONS_DEFINE= DOCS
-post-install:
-.if ${PORT_OPTIONS:MDOCS}
+post-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/,} ${STAGEDIR}${DOCSDIR}
-.endif
.include <bsd.port.mk>