aboutsummaryrefslogtreecommitdiffstats
path: root/x11/fireflies/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11/fireflies/Makefile')
-rw-r--r--x11/fireflies/Makefile13
1 files changed, 4 insertions, 9 deletions
diff --git a/x11/fireflies/Makefile b/x11/fireflies/Makefile
index fbe65c947d6d..4155efabc742 100644
--- a/x11/fireflies/Makefile
+++ b/x11/fireflies/Makefile
@@ -3,18 +3,19 @@
PORTNAME= fireflies
PORTVERSION= 2.07
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= x11
MASTER_SITES= http://somewhere.fscked.org/proj/fireflies/files/
MAINTAINER= umeno@rr.iij4u.or.jp
COMMENT= Extension of xscreensaver
-CONFLICTS= png-[0-9]*
+LIB_DEPENDS= gfx:${PORTSDIR}/graphics/libgfx
GNU_CONFIGURE= yes
-USE_GMAKE= yes
USE_GL= yes
+EXTRACT_AFTER_ARGS=--exclude '${DISTNAME}/libgfx*'
+MAKE_JOBS_SAFE= yes
CPPFLAGS+= -I${LOCALBASE}/include -I${LOCALBASE}/include/GL
LDFLAGS+= -L${LOCALBASE}/lib
@@ -26,10 +27,4 @@ MAKE_ARGS= CONFIGURE_ENV=${CONFIGURE_ENV:Q} \
CONFIGURE_SCRIPT=${CONFIGURE_SCRIPT:Q} \
CONFIGURE_ARGS=${CONFIGURE_ARGS:Q}
-post-extract:
- @(cd ${WRKSRC}; ${TAR} zxpf libgfx-1.0.1.tar.gz)
-
-post-patch:
- @${REINPLACE_CMD} -e 's|fltk|ignored-&|' ${WRKSRC}/libgfx/configure
-
.include <bsd.port.mk>