aboutsummaryrefslogtreecommitdiffstats
path: root/x11/gcursor/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11/gcursor/Makefile')
-rw-r--r--x11/gcursor/Makefile7
1 files changed, 4 insertions, 3 deletions
diff --git a/x11/gcursor/Makefile b/x11/gcursor/Makefile
index 4062c481c19f..5eed4317dec0 100644
--- a/x11/gcursor/Makefile
+++ b/x11/gcursor/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= gcursor
-PORTVERSION= 0.04
-PORTREVISION= 2
+PORTVERSION= 0.05
CATEGORIES= x11 gnome
MASTER_SITES= http://download.qballcow.nl/programs/gcursor/
@@ -19,7 +18,7 @@ RUN_DEPENDS= file-roller:${PORTSDIR}/archivers/fileroller
USE_GMAKE= yes
USE_X_PREFIX= yes
-USE_GNOME= gnomehack gnomeprefix gnometarget libgnomeui
+USE_GNOME= gnomehack gnomeprefix gnometarget intlhack libgnomeui
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
@@ -27,5 +26,7 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
post-patch:
@${REINPLACE_CMD} -e 's|%%X11BASE%%|${X11BASE}|g' \
${WRKSRC}/src/gcursor.c
+ @${REINPLACE_CMD} -e 's|share/applications|share/gnome/capplets|g' \
+ ${WRKSRC}/data/Makefile.in
.include <bsd.port.mk>