aboutsummaryrefslogtreecommitdiffstats
path: root/x11/gnome-applets/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11/gnome-applets/Makefile')
-rw-r--r--x11/gnome-applets/Makefile12
1 files changed, 7 insertions, 5 deletions
diff --git a/x11/gnome-applets/Makefile b/x11/gnome-applets/Makefile
index 16a2f08fc374..4d887a5dc32b 100644
--- a/x11/gnome-applets/Makefile
+++ b/x11/gnome-applets/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= gnomeapplets
-PORTVERSION= 1.4.0.1
-PORTREVISION= 1
+PORTVERSION= 1.4.0.2
CATEGORIES= x11 gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= stable/sources/gnome-applets
@@ -15,19 +14,22 @@ DISTNAME= gnome-applets-${PORTVERSION}
MAINTAINER= gnome@FreeBSD.org
+BUILD_DEPENDS= msgfmt-new:${PORTSDIR}/devel/gettext-devel
LIB_DEPENDS= gtop.1:${PORTSDIR}/devel/libgtop
USE_X_PREFIX= yes
USE_GMAKE= yes
USE_GNOME= yes
-USE_LIBTOOL= yes
+GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LIBS="-L${LOCALBASE}/lib"
+ LIBS="-L${LOCALBASE}/lib" \
+ MSGFMT=${LOCALBASE}/bin/msgfmt-new \
+ XGETTEXT=${LOCALBASE}/bin/xgettext-new
pre-patch:
@${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
- @find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
+ @find ${WRKSRC} -name "Makefile.in*" | xargs ${PERL} -pi -e \
's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
s|\$\(datadir\)/locale|\$\(prefix\)/share/locale|g'