aboutsummaryrefslogtreecommitdiffstats
path: root/x11/gnome-libs/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11/gnome-libs/Makefile')
-rw-r--r--x11/gnome-libs/Makefile7
1 files changed, 7 insertions, 0 deletions
diff --git a/x11/gnome-libs/Makefile b/x11/gnome-libs/Makefile
index 5eca7664198c..90b311d64e31 100644
--- a/x11/gnome-libs/Makefile
+++ b/x11/gnome-libs/Makefile
@@ -39,4 +39,11 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
MAN1= gnome.1 gnome-config.1
MAN5= gnome-mime.5
+post-extract:
+ @${PERL} -pi -e 's|-lpthread|-pthread|g ; \
+ s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
+ @find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
+ 's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
+ s|\$\(datadir\)/locale|\$\(prefix\)/share/locale|g'
+
.include <bsd.port.mk>