aboutsummaryrefslogtreecommitdiffstats
path: root/x11/gpctool/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11/gpctool/Makefile')
-rw-r--r--x11/gpctool/Makefile31
1 files changed, 31 insertions, 0 deletions
diff --git a/x11/gpctool/Makefile b/x11/gpctool/Makefile
new file mode 100644
index 000000000000..4af4a6724319
--- /dev/null
+++ b/x11/gpctool/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: gpc
+# Date created: 22 October 2005
+# Whom: Mikhail Teterin
+#
+# $FreeBSD$
+#
+
+PORTNAME= gpctool
+PORTVERSION= 1.0.1
+CATEGORIES= x11 math graphics
+MASTER_SITES= ftp://ftp.cs.man.ac.uk/pub/toby/gpc/
+DISTNAME= gpct${PORTVERSION:S/.//g}
+
+MAINTAINER= mi@aldan.algebra.com
+COMMENT= Evaluation tool for the Generic Polygon Clipper library
+
+LIB_DEPENDS= gpc:${PORTSDIR}/devel/gpc \
+ formsGL:${PORTSDIR}/x11-toolkits/xforms
+
+USE_ZIP= yes
+USE_GL= yes
+PLIST_FILES= bin/gpctool
+INSTALLS_SHLIB= yes
+NO_CDROM= Can't be used for profit without permission
+
+MAKEFILE= ${FILESDIR}/BSDmakefile
+
+EXTRACT_BEFORE_ARGS=-qoa
+EXTRACT_AFTER_ARGS=-d ${WRKDIR} -x ${DISTNAME}/gpc.? ${DISTNAME}/gl.c
+
+.include <bsd.port.mk>