aboutsummaryrefslogtreecommitdiffstats
path: root/x11/libXrandr/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11/libXrandr/Makefile')
-rw-r--r--x11/libXrandr/Makefile11
1 files changed, 5 insertions, 6 deletions
diff --git a/x11/libXrandr/Makefile b/x11/libXrandr/Makefile
index 79b8a8b621c4..551854557a10 100644
--- a/x11/libXrandr/Makefile
+++ b/x11/libXrandr/Makefile
@@ -6,17 +6,16 @@
#
PORTNAME= libXrandr
-PORTVERSION= 1.0.1.p1
+PORTVERSION= 1.0.2
CATEGORIES= x11
-MASTER_SITES= http://pdx.freedesktop.org/~anholt/dist/
+MASTER_SITES= http://pdx.freedesktop.org/~xlibs/release/
MAINTAINER= x11@FreeBSD.org
COMMENT= X Resize and Rotate extension library
LIB_PC_DEPENDS= ${X11BASE}/libdata/pkgconfig/xext.pc:${PORTSDIR}/x11/libXext \
- ${X11BASE}/libdata/pkgconfig/xrender.pc:${PORTSDIR}/x11-toolkits/xrender
-BUILD_DEPENDS= pkg-config:${PORTSDIR}/devel/pkgconfig \
- ${X11BASE}/libdata/pkgconfig/randr.pc:${PORTSDIR}/x11/randrext \
+ ${X11BASE}/libdata/pkgconfig/xrender.pc:${PORTSDIR}/x11/libXrender
+BUILD_DEPENDS= ${X11BASE}/libdata/pkgconfig/randr.pc:${PORTSDIR}/x11/randrext \
${X11BASE}/libdata/pkgconfig/xextensions.pc:${PORTSDIR}/x11/xextensions \
${LIB_PC_DEPENDS}
RUN_DEPENDS= ${LIB_PC_DEPENDS}
@@ -27,7 +26,7 @@ GNU_CONFIGURE= yes
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
USE_GMAKE= yes
CFLAGS+= -DMALLOC_0_RETURNS_NULL
-WRKSRC= ${WRKDIR}/${PORTNAME}-1.0.1
INSTALLS_SHLIB= yes
+USE_GNOME= gnomehack pkgconfig
.include <bsd.port.mk>