aboutsummaryrefslogtreecommitdiffstats
path: root/x11/libfm/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11/libfm/Makefile')
-rw-r--r--x11/libfm/Makefile25
1 files changed, 13 insertions, 12 deletions
diff --git a/x11/libfm/Makefile b/x11/libfm/Makefile
index 277d63a3cdfe..877d2fd6c4b1 100644
--- a/x11/libfm/Makefile
+++ b/x11/libfm/Makefile
@@ -1,33 +1,36 @@
-# New ports collection makefile for: x11-fm/libfm
-# Date created: 23 Sept 2010
-# Whom: Kris Moore <kmoore@freebsd.org>
-#
+# Created by: Kris Moore <kmoore@freebsd.org>
# $FreeBSD$
-#
PORTNAME= libfm
-PORTVERSION= 1.0
+PORTVERSION= 1.1.0
CATEGORIES= x11
MASTER_SITES= SF/pcmanfm/PCManFM%20%2B%20Libfm%20%28tarball%20release%29/libfm%20%28required%20by%20PCManFM%29/
MAINTAINER= kmoore@FreeBSD.org
COMMENT= The libFM backend library to PCManFM
+LICENSE= GPLv2
+
LIB_DEPENDS= startup-notification-1:${PORTSDIR}/x11/startup-notification \
menu-cache.1:${PORTSDIR}/x11/menu-cache
-USE_GNOME= gnomehack gtk20 pkgconfig
+USE_GNOME= gnomehack gtk20
USE_AUTOTOOLS= libtool
USE_GMAKE= yes
USE_FAM= yes
USE_LDCONFIG= yes
+USE_PKGCONFIG= yes
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-CONFIGURE_ARGS+=--prefix=${LOCALBASE} --sysconfdir=${LOCALBASE}/etc
+CONFIGURE_ARGS+=--sysconfdir=${LOCALBASE}/etc
MAN1= libfm-pref-apps.1
-.if !defined(WITHOUT_NLS)
+OPTIONS_DEFINE= NLS
+
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MNLS}
USE_GETTEXT= yes
PLIST_SUB+= NLS=""
.else
@@ -35,8 +38,6 @@ CONFIGURE_ARGS+=--disable-nls
PLIST_SUB+= NLS="@comment "
.endif
-.include <bsd.port.pre.mk>
-
post-patch:
@${REINPLACE_CMD} -e 's|-DG_DISABLE_DEPRECATED||g' \
${WRKSRC}/src/Makefile.in
@@ -47,4 +48,4 @@ post-patch:
pre-install:
cd ${WRKDIR}/libfm-${PORTVERSION} && ${CHMOD} 755 install-sh
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>