aboutsummaryrefslogtreecommitdiffstats
path: root/x11/libgnome/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11/libgnome/Makefile')
-rw-r--r--x11/libgnome/Makefile18
1 files changed, 11 insertions, 7 deletions
diff --git a/x11/libgnome/Makefile b/x11/libgnome/Makefile
index 8356bc83aa48..ecc70c77de87 100644
--- a/x11/libgnome/Makefile
+++ b/x11/libgnome/Makefile
@@ -16,16 +16,22 @@ DIST_SUBDIR= gnome2
MAINTAINER= gnome@FreeBSD.org
COMMENT= Libraries for GNOME, a GNU desktop environment
+USE_BZIP2= yes
+PREFIX?= ${X11BASE}
+
+.if !defined(REFERENCE_PORT)
+
+PORTREVISION= 1
+
BUILD_DEPENDS= scrollkeeper-config:${PORTSDIR}/textproc/scrollkeeper
RUN_DEPENDS= scrollkeeper-config:${PORTSDIR}/textproc/scrollkeeper
USE_GETTEXT= yes
-USE_BZIP2= yes
-USE_X_PREFIX= yes
+USE_XLIB= yes
USE_XPM= yes
USE_GMAKE= yes
USE_GNOME= gnomeprefix gnomehack intlhack esound \
- gnomevfs2 libxslt ltverhack
+ gnomevfs2 libxslt ltverhack referencehack
USE_BISON= yes
INSTALLS_SHLIB= yes
USE_AUTOTOOLS= libtool:15
@@ -54,9 +60,7 @@ post-patch:
@${REINPLACE_CMD} -e 's|%%LOCALBASE%%|${LOCALBASE}|' \
${WRKSRC}/libgnome/libgnome-2.0.pc.in
@${REINPLACE_CMD} -e '/^$$/d' ${WRKSRC}/po/POTFILES.in
-.if defined(NOPORTDOCS)
- @${REINPLACE_CMD} -e 's|gnome-data po doc|gnome-data po|g' \
- ${WRKSRC}/Makefile.in
-.endif
.include <bsd.port.mk>
+
+.endif