aboutsummaryrefslogtreecommitdiffstats
path: root/x11/mate-applets/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11/mate-applets/Makefile')
-rw-r--r--x11/mate-applets/Makefile51
1 files changed, 25 insertions, 26 deletions
diff --git a/x11/mate-applets/Makefile b/x11/mate-applets/Makefile
index f2c87d59f47c..001220dba37a 100644
--- a/x11/mate-applets/Makefile
+++ b/x11/mate-applets/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= mate-applets
-PORTVERSION= 1.6.1
-PORTREVISION= 3
+PORTVERSION= 1.8.0
CATEGORIES= x11 mate
MASTER_SITES= MATE
DIST_SUBDIR= mate
@@ -11,6 +10,7 @@ DIST_SUBDIR= mate
MAINTAINER= gnome@FreeBSD.org
COMMENT= Applets components for the MATE Desktop Environment
+BUILD_DEPENDS= itstool:${PORTSDIR}/textproc/itstool
LIB_DEPENDS= libgtop-2.0.so:${PORTSDIR}/devel/libgtop \
libxklavier.so:${PORTSDIR}/x11/libxklavier \
libdbus-1.so:${PORTSDIR}/devel/dbus \
@@ -19,32 +19,29 @@ LIB_DEPENDS= libgtop-2.0.so:${PORTSDIR}/devel/libgtop \
libhal.so:${PORTSDIR}/sysutils/hal \
libupower-glib.so:${PORTSDIR}/sysutils/upower \
libnotify.so:${PORTSDIR}/devel/libnotify
+RUN_DEPENDS= gucharmap:${PORTSDIR}/deskutils/gucharmap
PORTSCOUT= limitw:1,even
-USES= libtool gettext gmake pathfix pkgconfig tar:xz
-USE_MATE= autogen common:build desktop docutils icontheme intlhack \
- libmateweather libmatewnck mucharmap panel \
- polkit settingsdaemon
+USES= gettext gmake libtool pathfix pkgconfig python tar:xz
+USE_MATE= desktop icontheme libmateweather panel polkit settingsdaemon
USE_XORG= x11
-USE_GNOME= gdkpixbuf2 glib20 gnomehier gtk20 introspection:build \
- libxml2 libxslt pygobject pygtk2
-USE_PYTHON= yes
+USE_GNOME= gdkpixbuf2 gnomehier gtksourceview2 introspection:build \
+ libxml2 libxslt pygobject pygobject3 libwnck intlhack
USE_LDCONFIG= yes
-INSTALLS_OMF= yes
-USE_AUTOTOOLS= aclocal:env autoconf:env automake:env libtoolize:env
GNU_CONFIGURE= yes
INSTALLS_ICONS= yes
-CONFIGURE_ARGS= --enable-mixer-applet \
- --disable-networkmanager
+CONFIGURE_ARGS= --disable-networkmanager
CONFIGURE_ENV= OS_SYS="/usr/include"
CPPFLAGS+= -I${LOCALBASE}/include ${PTHREAD_CFLAGS}
LDFLAGS+= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
-PATHFIX_MAKEFILEIN= Makefile.*
+INSTALL_TARGET= install-strip
GLIB_SCHEMAS= org.mate.panel.applet.charpick.gschema.xml \
+ org.mate.panel.applet.command.gschema.xml \
org.mate.panel.applet.geyes.gschema.xml \
org.mate.panel.applet.multiload.gschema.xml \
+ org.mate.panel.applet.timer.gschema.xml \
org.mate.stickynotes.gschema.xml
FIX_APPLETS= accessx-status battstat charpick drivemount geyes \
@@ -52,24 +49,26 @@ FIX_APPLETS= accessx-status battstat charpick drivemount geyes \
.include <bsd.port.pre.mk>
-.if ${ARCH} != "i386" && ${ARCH} != "amd64"
+#.if ${ARCH} != "i386" && ${ARCH} != "amd64"
+CONFIGURE_ARGS+=--disable-battstat
CFLAGS+= -fPIC
PLIST_SUB+= BATTERY="@comment "
-.else
-GLIB_SCHEMAS+= org.mate.panel.applet.battstat.gschema.xml
-PLIST_SUB+= BATTERY=""
-.endif
+#.else
+#CONFIGURE_ARGS+=--enable-battstat
+#GLIB_SCHEMAS+= org.mate.panel.applet.battstat.gschema.xml
+#PLIST_SUB+= BATTERY=""
+#.endif
-.if ${ARCH} != "i386" && ${ARCH} != "amd64"
+#.if ${ARCH} != "i386" && ${ARCH} != "amd64"
+CONFIGURE_ARGS+=--disable-cpufreq
PLIST_SUB+= CPUFREQ="@comment "
-.else
-PLIST_SUB+= CPUFREQ=""
-GLIB_SCHEMAS+= org.mate.panel.applet.cpufreq.gschema.xml
-.endif
+#.else
+#CONFIGURE_ARGS+=--enable-cpufreq
+#PLIST_SUB+= CPUFREQ=""
+#GLIB_SCHEMAS+= org.mate.panel.applet.cpufreq.gschema.xml
+#.endif
post-patch:
- @${FIND} ${WRKSRC} -name Makefile.am | ${XARGS} ${REINPLACE_CMD} -e \
- 's|" == "|" = "|g'
${MV} ${WRKSRC}/invest-applet/invest/invest-applet.py \
${WRKSRC}/invest-applet/invest/mate-invest-applet.py
.for dir in ${FIX_APPLETS}