aboutsummaryrefslogtreecommitdiffstats
path: root/x11/py-qt4-opengl/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11/py-qt4-opengl/Makefile')
-rw-r--r--x11/py-qt4-opengl/Makefile9
1 files changed, 4 insertions, 5 deletions
diff --git a/x11/py-qt4-opengl/Makefile b/x11/py-qt4-opengl/Makefile
index a7ee4e56fc22..7daddbb269b3 100644
--- a/x11/py-qt4-opengl/Makefile
+++ b/x11/py-qt4-opengl/Makefile
@@ -8,11 +8,11 @@ CATEGORIES= x11 devel python
MAINTAINER= kde@FreeBSD.org
COMMENT= Python bindings for the Qt4 toolkit, QtOpenGL module
-BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}sip>=${SIP_VERSION}:${PORTSDIR}/devel/py-sip
-RUN_DEPENDS= ${PKGNAMEPREFIX}gui>=${PYQT4_VERSION}:${PORTSDIR}/x11-toolkits/py-qt4-gui
-
CONFIGURE_ARGS= --enable QtOpenGL
-PYQT4_DIST= yes
+PYQT_DIST= yes
+
+USES= python pyqt:4
+USE_PYQT= sip_build gui_run
USE_QT4= moc_build opengl qmake_build
OPTIONS_DEFINE= API DEBUG
@@ -25,5 +25,4 @@ API_CONFIGURE_OFF= --no-qsci-api
API_LIB_DEPENDS= libqscintilla2.so:${PORTSDIR}/devel/qscintilla2
DEBUG_CONFIGURE_ON= --debug --trace
-.include "${.CURDIR}/../../devel/py-qt4/bsd.pyqt.mk"
.include <bsd.port.mk>