aboutsummaryrefslogtreecommitdiffstats
path: root/x11/py-qt5-opengl/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11/py-qt5-opengl/Makefile')
-rw-r--r--x11/py-qt5-opengl/Makefile27
1 files changed, 27 insertions, 0 deletions
diff --git a/x11/py-qt5-opengl/Makefile b/x11/py-qt5-opengl/Makefile
new file mode 100644
index 000000000000..893416cbc360
--- /dev/null
+++ b/x11/py-qt5-opengl/Makefile
@@ -0,0 +1,27 @@
+# $FreeBSD$
+
+PORTNAME= opengl
+CATEGORIES= x11 devel python
+
+MAINTAINER= kde@FreeBSD.org
+COMMENT= Python bindings for the Qt5 toolkit, QtOpenGL module
+
+CONFIGURE_ARGS= --enable QtOpenGL
+PYQT_DIST= yes
+
+USES= python pyqt:5
+USE_GL= gl
+USE_PYQT= sip_build core_run gui_run widgets_run
+USE_QT5= core gui opengl widgets qmake_build
+
+OPTIONS_DEFINE= API DEBUG
+OPTIONS_DEFAULT=API
+OPTIONS_SUB= yes
+
+API_DESC= Install QtOpenGL API for QScintilla2
+API_CONFIGURE_ON= --qsci-api --qsci-api-destdir=${QSCIDIR}
+API_CONFIGURE_OFF= --no-qsci-api
+API_LIB_DEPENDS= libqscintilla2-qt5.so:${PORTSDIR}/devel/qscintilla2-qt5
+DEBUG_CONFIGURE_ON= --debug --trace
+
+.include <bsd.port.mk>