aboutsummaryrefslogtreecommitdiffstats
path: root/x11/qt4-opengl/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11/qt4-opengl/Makefile')
-rw-r--r--x11/qt4-opengl/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/x11/qt4-opengl/Makefile b/x11/qt4-opengl/Makefile
index ab1fe269efac..0e5fd03abf36 100644
--- a/x11/qt4-opengl/Makefile
+++ b/x11/qt4-opengl/Makefile
@@ -8,6 +8,7 @@
PORTNAME= opengl
PORTVERSION= ${QT4_VERSION}
+PORTREVISION=0
CATEGORIES?= x11
MASTER_SITES= ${MASTER_SITE_QT}
PKGNAMEPREFIX= qt4-
@@ -26,6 +27,7 @@ HAS_CONFIGURE= yes
USE_LDCONFIG= ${PREFIX}/lib/qt4
USE_GL= glu
USE_XORG= x11
+MAKE_JOBS_SAFE= yes
ALL_TARGET= first
CONFIGURE_ENV?= QTDIR=${WRKSRC} PATH=${WRKSRC}/bin:$$PATH
@@ -45,6 +47,8 @@ EXTRACT_AFTER_ARGS+= --exclude '${DISTNAME}/${dne}'
WRKSRC= ${WRKDIR}/${DISTNAME}/src/${PORTNAME}
CONFIGURE_WRKSRC=${WRKSRC}/../../
+CONFIGURE_ARGS+= -I../../include/Qt -I../../include
+
pre-configure:
${CP} ${.CURDIR}/../../devel/qt4/files/configure ${CONFIGURE_WRKSRC}
${MKDIR} ${WRKSRC}/../../mkspecs