aboutsummaryrefslogtreecommitdiffstats
path: root/x11/qt4-opengl/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11/qt4-opengl/Makefile')
-rw-r--r--x11/qt4-opengl/Makefile58
1 files changed, 0 insertions, 58 deletions
diff --git a/x11/qt4-opengl/Makefile b/x11/qt4-opengl/Makefile
deleted file mode 100644
index 788da18f3416..000000000000
--- a/x11/qt4-opengl/Makefile
+++ /dev/null
@@ -1,58 +0,0 @@
-# Created by: lofi@FreeBSD.org
-# $FreeBSD$
-
-PORTNAME= opengl
-DISTVERSION= ${QT4_VERSION}
-CATEGORIES?= x11
-PKGNAMEPREFIX= qt4-
-
-MAINTAINER= kde@FreeBSD.org
-COMMENT= Qt OpenGL library
-
-USE_QT4= qmake_build moc_build corelib gui
-QT_NONSTANDARD= yes
-QT_DIST= yes
-
-HAS_CONFIGURE= yes
-USE_LDCONFIG= ${PREFIX}/lib/qt4
-USE_GL= gl
-USE_XORG= x11
-
-ALL_TARGET= first
-CONFIGURE_ENV?= QTDIR=${WRKSRC} PATH=${WRKSRC}/bin:$$PATH
-MAKE_ENV?= QTDIR=${WRKSRC} LD_LIBRARY_PATH=${WRKSRC}/lib:$$LD_LIBRARY_PATH \
- PATH=${WRKSRC}/bin:$$PATH
-
-DO_NOT_EXTRACT= demos doc examples mkspecs qmake tools translations \
- src/activeqt src/dbus src/multimedia src/network src/openvg \
- src/phonon src/qt3support src/s60installs src/s60main \
- src/script src/scripttools src/sql src/svg src/testlib \
- src/tools src/winmain src/xml src/xmlpatterns \
- src/3rdparty/clucene src/3rdparty/freetype \
- src/3rdparty/libjpeg src/3rdparty/libmng src/3rdparty/libpng \
- src/3rdparty/libtiff src/3rdparty/phonon src/3rdparty/webkit
-.for dne in ${DO_NOT_EXTRACT}
-EXTRACT_AFTER_ARGS+= --exclude '${DISTNAME}/${dne}'
-.endfor
-
-BUILD_WRKSRC= ${WRKSRC}/src/${PORTNAME}
-INSTALL_WRKSRC= ${BUILD_WRKSRC}
-
-CONFIGURE_ARGS+= -I../../include/QtCore -I../../include/QtGui \
- -I../../include/Qt -I../../include
-
-EXTRA_PATCHES+= ${.CURDIR}/../../devel/qt4/files/patch-configure
-
-pre-configure:
- ${MKDIR} ${WRKSRC}/mkspecs
- ${LN} -sf ${LOCALBASE}/bin/qmake-qt4 ${WRKSRC}/bin/qmake
- ${LN} -sf ${LOCALBASE}/bin/moc-qt4 ${WRKSRC}/bin/moc
-
-post-configure:
- ${REINPLACE_CMD} -e 's|${PREFIX}/lib/qt4/pkgconfig|${PREFIX}/libdata/pkgconfig|g' \
- -e 's|.*$$(QMAKE).*||g' ${BUILD_WRKSRC}/Makefile
- ${REINPLACE_CMD} -E -e 's|-L.[^[:space:]]*qt-x11-opensource.[^[:space:]]*lib||g' \
- -E -e 's|(.*location=).*moc|\1${PREFIX}/bin/moc-qt4|g' \
- ${WRKSRC}/lib/pkgconfig/QtOpenGL.pc
-
-.include <bsd.port.mk>