aboutsummaryrefslogtreecommitdiffstats
path: root/x11/qt5-qev/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11/qt5-qev/Makefile')
-rw-r--r--x11/qt5-qev/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/x11/qt5-qev/Makefile b/x11/qt5-qev/Makefile
index 06c302b52908..c769bf53e5a9 100644
--- a/x11/qt5-qev/Makefile
+++ b/x11/qt5-qev/Makefile
@@ -2,7 +2,6 @@
PORTNAME= qev
DISTVERSION= ${QT5_VERSION}
-PORTREVISION= 1
CATEGORIES= x11
PKGNAMEPREFIX= qt5-
@@ -15,4 +14,11 @@ USES= qmake
WRKSRC_SUBDIR= src/${PORTNAME}
+# qev is not connected to qttool's build system, so we cannot just run qmake
+# and set {BUILD,INSTALL}_WRKSRC.
+# Instead, we run qmake from src/${PORTNAME} but need to copy .qmake.conf to
+# it for all required variables to be set (MODULE_VERSION etc).
+post-patch:
+ ${CP} ${WRKSRC}/../../.qmake.conf ${WRKSRC}
+
.include <bsd.port.mk>