aboutsummaryrefslogtreecommitdiffstats
path: root/x11/tycoon/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11/tycoon/Makefile')
-rw-r--r--x11/tycoon/Makefile17
1 files changed, 9 insertions, 8 deletions
diff --git a/x11/tycoon/Makefile b/x11/tycoon/Makefile
index 3c844575d7fd..6c2944935f62 100644
--- a/x11/tycoon/Makefile
+++ b/x11/tycoon/Makefile
@@ -5,24 +5,25 @@ PORTNAME= tycoon
PORTVERSION= 1.07o
PORTREVISION= 5
CATEGORIES= x11
-MASTER_SITES= ${MASTER_SITE_SUNSITE}
-MASTER_SITE_SUBDIR= X11/desktop
+MASTER_SITES= SUNSITE/X11/desktop
MAINTAINER= ports@FreeBSD.org
COMMENT= Nifty set of desktop apps, including floating buttons
-LIB_DEPENDS= forms.2:${PORTSDIR}/x11-toolkits/xforms
+LIB_DEPENDS= libforms.so:${PORTSDIR}/x11-toolkits/xforms
USES= imake
USE_XORG= xaw
-REINPLACE_ARGS= -i ""
-NO_STAGE= yes
post-patch:
- ${RM} -f ${WRKSRC}/xbackdrop/backdrops/index~
- ${REINPLACE_CMD} -e 's,/usr/lib,${PREFIX}/lib,' \
+ @${REINPLACE_CMD} -e 's,/usr/lib,${PREFIX}/lib,' \
${WRKSRC}/xbackdrop/backdrops/index
- ${FIND} ${WRKSRC} -name '*.c' -type f | ${XARGS} ${REINPLACE_CMD} -e \
+ @${REINPLACE_CMD} -e 's|^update_file|void update_file|' \
+ ${WRKSRC}/xchooser/xchooser.c
+ @${FIND} ${WRKSRC} -name '*.c' -type f | ${XARGS} ${REINPLACE_CMD} -e \
's,FL_REVISION>=80,FL_REVISION >= 80 || FL_VERSION != 0,g'
+pre-configure:
+ @${RM} -f ${WRKSRC}/xbackdrop/backdrops/index?*
+
.include <bsd.port.mk>