aboutsummaryrefslogtreecommitdiffstats
path: root/x11/xdialog/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11/xdialog/Makefile')
-rw-r--r--x11/xdialog/Makefile6
1 files changed, 5 insertions, 1 deletions
diff --git a/x11/xdialog/Makefile b/x11/xdialog/Makefile
index 3de69a5054e4..8be4d3d6efc3 100644
--- a/x11/xdialog/Makefile
+++ b/x11/xdialog/Makefile
@@ -8,6 +8,7 @@
PORTNAME= xdialog
PORTVERSION= 2.3.1
+PORTREVISION= 1
CATEGORIES= x11
MASTER_SITES= http://thgodef.nerim.net/xdialog/
DISTNAME= ${PORTNAME:S/x/X/}-${PORTVERSION}
@@ -41,12 +42,15 @@ post-patch:
s|-I../lib||g ; \
s|-L../lib -lgetopt||g ; \
s| install-docDATA||g'
+ @${REINPLACE_CMD} -e 's,Xdialog\\-%%version%%,xdialog,' \
+ ${WRKSRC}/doc/Xdialog.man
post-install:
.if !defined(NOPORTDOCS)
- @${MKDIR} ${DOCSDIR}
+ @${MKDIR} ${DOCSDIR}/samples
${INSTALL_DATA} ${WRKSRC}/doc/*.html ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/doc/*.png ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/samples/* ${DOCSDIR}/samples
.endif
.include <bsd.port.mk>