aboutsummaryrefslogtreecommitdiffstats
path: root/x11/xfce4-embed-plugin/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11/xfce4-embed-plugin/Makefile')
-rw-r--r--x11/xfce4-embed-plugin/Makefile38
1 files changed, 38 insertions, 0 deletions
diff --git a/x11/xfce4-embed-plugin/Makefile b/x11/xfce4-embed-plugin/Makefile
new file mode 100644
index 000000000000..2dfd2605dfbf
--- /dev/null
+++ b/x11/xfce4-embed-plugin/Makefile
@@ -0,0 +1,38 @@
+# Created by: Olivier Duchateau
+# $FreeBSD$
+#
+
+PORTNAME= xfce4-embed-plugin
+PORTVERSION= 1.4.1
+CATEGORIES= x11 xfce
+MASTER_SITES= ${MASTER_SITE_XFCE}
+MASTER_SITE_SUBDIR= src/panel-plugins/${PORTNAME}/${PORTVERSION:R}
+DIST_SUBDIR= xfce4
+
+MAINTAINER= xfce@FreeBSD.org
+COMMENT= Embed arbitrary windows into the Xfce panel
+
+USE_BZIP2= yes
+USE_AUTOTOOLS= libtool
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+USES= pkgconfig
+USE_XORG= x11
+USE_GNOME= glib20 gtk20 intltool intlhack
+USE_XFCE= configenv libmenu libutil panel
+
+OPTIONS_DEFINE= NLS
+
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MNLS}
+USES+= gettext
+CONFIGURE_ARGS+=--enable-nls
+PLIST_SUB+= NLS=""
+.else
+EXTRA_PATCHES= ${FILESDIR}/extra-patch-configure
+CONFIGURE_ARGS+=--disable-nls
+PLIST_SUB+= NLS="@comment "
+.endif
+
+.include <bsd.port.mk>