aboutsummaryrefslogtreecommitdiffstats
path: root/x11/xsel/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11/xsel/Makefile')
-rw-r--r--x11/xsel/Makefile36
1 files changed, 36 insertions, 0 deletions
diff --git a/x11/xsel/Makefile b/x11/xsel/Makefile
new file mode 100644
index 000000000000..078afaa293bd
--- /dev/null
+++ b/x11/xsel/Makefile
@@ -0,0 +1,36 @@
+# ex:ts=8
+# Ports collection makefile for: xsel
+# Date created: Jan 14, 2003
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= xsel
+PORTVERSION= 0.04.1
+CATEGORIES= x11
+MASTER_SITES= http://www.niksula.cs.hut.fi/~vherva/xsel/
+DISTFILES= xsel.c xsel.man
+
+MAINTAINER= ports@FreeBSD.org
+
+EXTRACT_CMD= ${CP}
+EXTRACT_BEFORE_ARGS=
+EXTRACT_AFTER_ARGS= ${WRKDIR}
+USE_XLIB= yes
+USE_GNOMENG= yes
+USE_GNOME= gtk12
+NO_WRKSUBDIR= yes
+CFLAGS+= `${GTK_CONFIG} --cflags`
+LDFLAGS+= `${GTK_CONFIG} --libs` -lXt -lXaw
+
+MAN1= xsel.1
+
+do-build:
+ (cd ${WRKSRC} && ${CC} ${CFLAGS} xsel.c -o xsel ${LDFLAGS})
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/xsel ${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/xsel.man ${MAN1PREFIX}/man/man1/xsel.1
+
+.include <bsd.port.mk>