aboutsummaryrefslogtreecommitdiffstats
path: root/x11/xxkb/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11/xxkb/Makefile')
-rw-r--r--x11/xxkb/Makefile55
1 files changed, 30 insertions, 25 deletions
diff --git a/x11/xxkb/Makefile b/x11/xxkb/Makefile
index b5b7ce99ddf8..971ef09f0f5d 100644
--- a/x11/xxkb/Makefile
+++ b/x11/xxkb/Makefile
@@ -1,40 +1,45 @@
-# New ports collection makefile for: xxkb
-# Date created: 5 Mar 2001
-# Whom: Alexander Matey <matey@cis.ohio-state.edu>
-#
+# Created by: Alexander Matey <matey@cis.ohio-state.edu>
# $FreeBSD$
-#
-PORTNAME= xxkb
-PORTVERSION= 1.11
-CATEGORIES= x11
-MASTER_SITES= SF
-DISTNAME= ${PORTNAME}-${PORTVERSION}-src
+PORTNAME= xxkb
+PORTVERSION= 1.11
+CATEGORIES= x11
+MASTER_SITES= SF
+DISTNAME= ${PORTNAME}-${PORTVERSION}-src
-MAINTAINER= alexander.pohoyda@gmx.net
-COMMENT= An XKB keyboard layout switcher and indicator
+MAINTAINER= alexander.pohoyda@gmx.net
+COMMENT= XKB keyboard layout indicator and switcher
-WRKSRC= ${WRKDIR}/${PORTNAME}
-USE_XORG= xpm
-USE_IMAKE= yes
+LICENSE= ART10
-MAN1= xxkb.1
+BUILD_DEPENDS= iconv:${PORTSDIR}/converters/libiconv
-OPTIONS= LIBRSVG "With SVG(librsvg2) support" off
+USE_XORG= xpm
+USE_IMAKE= yes
+WRKSRC= ${WRKDIR}/${PORTNAME}
+
+MAN1= ${PORTNAME}.1
+PORTDOCS= README CHANGES.ru README.ru
+
+OPTIONS_DEFINE= LIBRSVG2 DOCS
.include <bsd.port.pre.mk>
-.if defined(WITH_LIBRSVG)
-LIB_DEPENDS+= rsvg-2.2:${PORTSDIR}/graphics/librsvg2
-XMKMF= xmkmf -a -DWITH_SVG_SUPPORT
+.if ${PORT_OPTIONS:MLIBRSVG2}
+LIB_DEPENDS= rsvg-2:${PORTSDIR}/graphics/librsvg2
+XMKMF= xmkmf -a -DWITH_SVG_SUPPORT
.endif
+post-build:
+# Convert Russian language docs from archaic KOI8-R to modern UTF-8
+.for f in CHANGES README
+ iconv -f koi8-r -t utf-8 ${WRKSRC}/${f}.koi8 > ${WRKSRC}/${f}.ru
+.endfor
+
post-install:
-.if !defined(NOPORTDOCS)
- ${MKDIR} ${DOCSDIR}
-. for file in LICENSE README CHANGES.koi8 README.koi8
- ${INSTALL_DATA} ${WRKSRC}/${file} ${DOCSDIR}
-. endfor
+.if ${PORT_OPTIONS:MDOCS}
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/,} ${DOCSDIR}
.endif
.include <bsd.port.post.mk>