aboutsummaryrefslogtreecommitdiffstats
path: root/x11/zenity/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11/zenity/Makefile')
-rw-r--r--x11/zenity/Makefile31
1 files changed, 16 insertions, 15 deletions
diff --git a/x11/zenity/Makefile b/x11/zenity/Makefile
index a9e6076d3441..97da62f75198 100644
--- a/x11/zenity/Makefile
+++ b/x11/zenity/Makefile
@@ -1,34 +1,35 @@
# Created by: Franz Klammer <klammer@webonaut.com>
# $FreeBSD$
-# $MCom: ports/x11/zenity/Makefile,v 1.119 2013/01/09 18:51:14 kwm Exp $
+# $MCom: ports/trunk/x11/zenity/Makefile 19968 2014-10-16 07:29:56Z gusi $
PORTNAME= zenity
-PORTVERSION= 2.32.1
-PORTREVISION= 3
+PORTVERSION= 3.14.0
CATEGORIES= x11 gnome
MASTER_SITES= GNOME
-DIST_SUBDIR= gnome2
+DIST_SUBDIR= gnome3
MAINTAINER= gnome@FreeBSD.org
COMMENT= Display GNOME dialogs from the command line
-BUILD_DEPENDS= rarian-sk-config:${PORTSDIR}/textproc/rarian
-RUN_DEPENDS= rarian-sk-config:${PORTSDIR}/textproc/rarian
+LICENSE= LGPL20
-USES= pathfix perl5 gettext gmake pkgconfig tar:bzip2
-USE_PERL5= run
-USE_GNOME= gnomeprefix gtk20 gnomedocutils intlhack
+BUILD_DEPENDS= itstool:${PORTSDIR}/textproc/itstool
+
+CONFLICTS= gtkada-1.2.* zenity-2.*
+
+USES= gettext gmake pathfix pkgconfig perl5 tar:xz
+USE_GNOME= gnomeprefix gtk30 intlhack
+USE_XORG= x11
GNU_CONFIGURE= yes
-INSTALLS_OMF= yes
CPPFLAGS+= -I${LOCALBASE}/include
-LIBS+= -L${LOCALBASE}/lib -lintl
-
-CONFLICTS= gtkada-1.2.*
+LDFLAGS+= -L${LOCALBASE}/lib
OPTIONS_DEFINE= NOTIFY
OPTIONS_DEFAULT=NOTIFY
-
NOTIFY_LIB_DEPENDS= libnotify.so:${PORTSDIR}/devel/libnotify
-NOTIFY_CONFIGURE_ENABLE= libnotify
+NOTIFY_CONFIGURE_ENABLE=libnotify
+
+post-patch:
+ @${RM} ${WRKSRC}/src/gdialog
.include <bsd.port.mk>