aboutsummaryrefslogtreecommitdiffstats
path: root/x11/zenity
diff options
context:
space:
mode:
Diffstat (limited to 'x11/zenity')
-rw-r--r--x11/zenity/Makefile3
-rw-r--r--x11/zenity/files/patch-src_notification.c15
2 files changed, 17 insertions, 1 deletions
diff --git a/x11/zenity/Makefile b/x11/zenity/Makefile
index aae55592f2bc..03ccc5ea658d 100644
--- a/x11/zenity/Makefile
+++ b/x11/zenity/Makefile
@@ -8,6 +8,7 @@
PORTNAME= zenity
PORTVERSION= 2.32.1
+PORTREVISION= 1
CATEGORIES= x11 gnome
MASTER_SITES= GNOME
DIST_SUBDIR= gnome2
@@ -36,7 +37,7 @@ OPTIONS= NOTIFY "Enable libnotify support" on
.include <bsd.port.pre.mk>
.if !defined(WITHOUT_NOTIFY)
-LIB_DEPENDS+= notify.1:${PORTSDIR}/devel/libnotify
+LIB_DEPENDS+= notify.4:${PORTSDIR}/devel/libnotify
CONFIGURE_ARGS+= --enable-libnotify
.else
CONFIGURE_ARGS+= --disable-libnotify
diff --git a/x11/zenity/files/patch-src_notification.c b/x11/zenity/files/patch-src_notification.c
new file mode 100644
index 000000000000..2acdb9b30bf2
--- /dev/null
+++ b/x11/zenity/files/patch-src_notification.c
@@ -0,0 +1,15 @@
+--- src/notification.c.orig 2011-08-11 11:03:46.000000000 +0200
++++ src/notification.c 2011-08-11 11:05:21.000000000 +0200
+@@ -184,10 +184,10 @@
+ icon = freeme = g_filename_to_uri (icon_file, NULL, NULL);
+ }
+
+- notif = notify_notification_new_with_status_icon (
++ notif = notify_notification_new (
+ message[0] /* title */,
+ message[1] /* summary */,
+- icon, status_icon);
++ icon);
+
+ g_strfreev (message);
+ g_free (freeme);