aboutsummaryrefslogtreecommitdiffstats
path: root/x11
diff options
context:
space:
mode:
Diffstat (limited to 'x11')
-rw-r--r--x11/gdm2/Makefile2
-rw-r--r--x11/gdm2/files/patch-gui_gdmsetup.c11
2 files changed, 12 insertions, 1 deletions
diff --git a/x11/gdm2/Makefile b/x11/gdm2/Makefile
index c4f5dddaae50..62ff6ec5f898 100644
--- a/x11/gdm2/Makefile
+++ b/x11/gdm2/Makefile
@@ -7,7 +7,7 @@
PORTNAME= gdm2
PORTVERSION= 2.6.0.0
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= x11 gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= sources/${PORTNAME:S/2$//}/2.6
diff --git a/x11/gdm2/files/patch-gui_gdmsetup.c b/x11/gdm2/files/patch-gui_gdmsetup.c
new file mode 100644
index 000000000000..aad93e0baafc
--- /dev/null
+++ b/x11/gdm2/files/patch-gui_gdmsetup.c
@@ -0,0 +1,11 @@
+--- gui/gdmsetup.c.orig Mon Apr 12 14:24:57 2004
++++ gui/gdmsetup.c Mon Apr 12 14:25:00 2004
+@@ -1962,7 +1962,7 @@
+ success = TRUE;
+
+ /* HACK! */
+- cmd = g_strdup_printf ("%s -R root.root %s", chown, quoted);
++ cmd = g_strdup_printf ("%s -R root:wheel %s", chown, quoted);
+ system (cmd);
+ g_free (cmd);
+