aboutsummaryrefslogtreecommitdiffstats
path: root/x11
diff options
context:
space:
mode:
Diffstat (limited to 'x11')
-rw-r--r--x11/gnome-terminal/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/x11/gnome-terminal/Makefile b/x11/gnome-terminal/Makefile
index e696c216176e..b8ee9375f3cb 100644
--- a/x11/gnome-terminal/Makefile
+++ b/x11/gnome-terminal/Makefile
@@ -16,7 +16,7 @@ LIB_DEPENDS= libstartup-notification-1.so:${PORTSDIR}/x11/startup-notification
USES= gettext gmake libtool pathfix pkgconfig tar:bzip2
INSTALLS_OMF= yes
-USE_XORG= sm
+USE_XORG= ice sm
USE_GNOME= gnomeprefix intlhack gconf2 vte gnomedocutils libgnome
GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include
@@ -27,5 +27,7 @@ GCONF_SCHEMAS= gnome-terminal.schemas
post-patch:
@${TOUCH} ${WRKSRC}/aclocal.m4 ${WRKSRC}/Makefile.in \
${WRKSRC}/configure ${WRKSRC}/config.h.in
+ @${REINPLACE_CMD} '/SMCLIENT_LIBS =/s/$$/ -lICE/' \
+ ${WRKSRC}/src/Makefile.in
.include <bsd.port.mk>