aboutsummaryrefslogtreecommitdiffstats
path: root/x11
diff options
context:
space:
mode:
Diffstat (limited to 'x11')
-rw-r--r--x11/libxfce4mcs/Makefile15
-rw-r--r--x11/libxfce4mcs/distinfo4
-rw-r--r--x11/libxfce4mcs/pkg-plist20
-rw-r--r--x11/libxfce4util/Makefile15
-rw-r--r--x11/libxfce4util/distinfo4
-rw-r--r--x11/libxfce4util/pkg-plist36
-rw-r--r--x11/xfce4-clipman-plugin/Makefile4
-rw-r--r--x11/xfce4-trigger-launcher/Makefile12
-rw-r--r--x11/xfce4-trigger-launcher/distinfo4
-rw-r--r--x11/xfce4-trigger-launcher/pkg-plist3
10 files changed, 88 insertions, 29 deletions
diff --git a/x11/libxfce4mcs/Makefile b/x11/libxfce4mcs/Makefile
index b4374140b62a..4c39415a662d 100644
--- a/x11/libxfce4mcs/Makefile
+++ b/x11/libxfce4mcs/Makefile
@@ -6,11 +6,12 @@
#
PORTNAME= libxfce4mcs
-PORTVERSION= 4.0.6
+PORTVERSION= 4.2.0
PORTREVISION= 0
CATEGORIES= x11 xfce
-MASTER_SITES= ftp://ftp.berlios.de/pub/xfce-goodies/${PORTVERSION}/ \
- http://hannelore.f1.fhtw-berlin.de/mirrors/xfce4/xfce-${PORTVERSION}/src/
+MASTER_SITES= http://www.us.xfce.org/archive/xfce-${PORTVERSION}/src/ \
+ http://spuriousinterrupt.org/projects/xfce4/files/mirror/xfce-${PORTVERSION}/ \
+ http://public.fh-wolfenbuettel.de/~luedickj/xfce4/xfce-${PORTVERSION}/
DIST_SUBDIR= xfce4
MAINTAINER= oliver@FreeBSD.org
@@ -25,6 +26,14 @@ GNU_CONFIGURE= yes
CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
INSTALLS_SHLIB= yes
NO_FILTER_SHLIBS= yes
+USE_LIBTOOL_VER=15
+
+.if defined(WITH_GTKDOC)
+BUILD_DEPENDS+= gtkdocize:${PORTSDIR}/textproc/gtk-doc
+CONFIGURE_ARGS+=--enable-gtk-doc
+.else
+CONFIGURE_ARGS+=--disable-gtk-doc
+.endif
post-patch:
@${REINPLACE_CMD} -e 's|$$(libdir)/pkgconfig|${PREFIX}/libdata/pkgconfig|g' \
diff --git a/x11/libxfce4mcs/distinfo b/x11/libxfce4mcs/distinfo
index c74a084e19ef..603deba488fe 100644
--- a/x11/libxfce4mcs/distinfo
+++ b/x11/libxfce4mcs/distinfo
@@ -1,2 +1,2 @@
-MD5 (xfce4/libxfce4mcs-4.0.6.tar.gz) = ebbe2f4934d79c596d2a48c0cbf6ed33
-SIZE(xfce4/libxfce4mcs-4.0.6.tar.gz) = 330016
+MD5 (xfce4/libxfce4mcs-4.2.0.tar.gz) = fa0ca0a182b90c492d1b62e828c800d6
+SIZE(xfce4/libxfce4mcs-4.2.0.tar.gz) = 369645
diff --git a/x11/libxfce4mcs/pkg-plist b/x11/libxfce4mcs/pkg-plist
index cc7d1a25f5a0..83d858462d6c 100644
--- a/x11/libxfce4mcs/pkg-plist
+++ b/x11/libxfce4mcs/pkg-plist
@@ -2,14 +2,26 @@ include/xfce4/libxfce4mcs/mcs-client.h
include/xfce4/libxfce4mcs/mcs-common.h
include/xfce4/libxfce4mcs/mcs-manager.h
lib/libxfce4mcs-client.a
-lib/libxfce4mcs-client.la
lib/libxfce4mcs-client.so
-lib/libxfce4mcs-client.so.1
+lib/libxfce4mcs-client.so.2
lib/libxfce4mcs-manager.a
-lib/libxfce4mcs-manager.la
lib/libxfce4mcs-manager.so
-lib/libxfce4mcs-manager.so.1
+lib/libxfce4mcs-manager.so.2
libdata/pkgconfig/libxfce4mcs-manager-1.0.pc
libdata/pkgconfig/libxfce4mcs-client-1.0.pc
+share/gtk-doc/html/libxfce4mcs/ch01.html
+share/gtk-doc/html/libxfce4mcs/home.png
+share/gtk-doc/html/libxfce4mcs/index.html
+share/gtk-doc/html/libxfce4mcs/index.sgml
+share/gtk-doc/html/libxfce4mcs/left.png
+share/gtk-doc/html/libxfce4mcs/libxfce4mcs-mcs-client.html
+share/gtk-doc/html/libxfce4mcs/libxfce4mcs-mcs-common.html
+share/gtk-doc/html/libxfce4mcs/libxfce4mcs-mcs-manager.html
+share/gtk-doc/html/libxfce4mcs/libxfce4mcs.devhelp
+share/gtk-doc/html/libxfce4mcs/right.png
+share/gtk-doc/html/libxfce4mcs/up.png
@dirrm include/xfce4/libxfce4mcs
+@dirrm share/gtk-doc/html/libxfce4mcs
+@unexec rmdir %D/share/gtk-doc/html 2>/dev/null || true
+@unexec rmdir %D/share/gtk-doc 2>/dev/null || true
@unexec rmdir %D/include/xfce4 2>/dev/null || true
diff --git a/x11/libxfce4util/Makefile b/x11/libxfce4util/Makefile
index 2a8ca1950842..b46f691828a9 100644
--- a/x11/libxfce4util/Makefile
+++ b/x11/libxfce4util/Makefile
@@ -6,11 +6,12 @@
#
PORTNAME= libxfce4util
-PORTVERSION= 4.0.6
+PORTVERSION= 4.2.0
PORTREVISION= 0
CATEGORIES= x11 xfce
-MASTER_SITES= ftp://ftp.berlios.de/pub/xfce-goodies/${PORTVERSION}/ \
- http://hannelore.f1.fhtw-berlin.de/mirrors/xfce4/xfce-${PORTVERSION}/src/
+MASTER_SITES= http://www.us.xfce.org/archive/xfce-${PORTVERSION}/src/ \
+ http://spuriousinterrupt.org/projects/xfce4/files/mirror/xfce-${PORTVERSION}/ \
+ http://public.fh-wolfenbuettel.de/~luedickj/xfce4/xfce-${PORTVERSION}/
DIST_SUBDIR= xfce4
MAINTAINER= oliver@FreeBSD.org
@@ -23,6 +24,14 @@ GNU_CONFIGURE= yes
CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
INSTALLS_SHLIB= yes
NO_FILTER_SHLIBS= yes
+USE_LIBTOOL_VER=15
+
+.if defined(WITH_GTKDOC)
+BUILD_DEPENDS+= gtkdocize:${PORTSDIR}/textproc/gtk-doc
+CONFIGURE_ARGS+=--enable-gtk-doc
+.else
+CONFIGURE_ARGS+=--disable-gtk-doc
+.endif
post-patch:
@${REINPLACE_CMD} -e 's|$$(libdir)/pkgconfig|${PREFIX}/libdata/pkgconfig|g' \
diff --git a/x11/libxfce4util/distinfo b/x11/libxfce4util/distinfo
index 113cdec49d24..2b5af30da70b 100644
--- a/x11/libxfce4util/distinfo
+++ b/x11/libxfce4util/distinfo
@@ -1,2 +1,2 @@
-MD5 (xfce4/libxfce4util-4.0.6.tar.gz) = 4945103c0bd36f53d108bc49b4994f80
-SIZE(xfce4/libxfce4util-4.0.6.tar.gz) = 314842
+MD5 (xfce4/libxfce4util-4.2.0.tar.gz) = b80354f6e68cd63ded05a2026e90c325
+SIZE(xfce4/libxfce4util-4.2.0.tar.gz) = 447408
diff --git a/x11/libxfce4util/pkg-plist b/x11/libxfce4util/pkg-plist
index 86b1f79c827f..b4c5bfa31208 100644
--- a/x11/libxfce4util/pkg-plist
+++ b/x11/libxfce4util/pkg-plist
@@ -4,18 +4,48 @@ include/xfce4/libxfce4util/libxfce4util.h
include/xfce4/libxfce4util/libxfce4util-config.h
include/xfce4/libxfce4util/utf8.h
include/xfce4/libxfce4util/util.h
+include/xfce4/libxfce4util/xfce-desktopentry.h
+include/xfce4/libxfce4util/xfce-fileutils.h
+include/xfce4/libxfce4util/xfce-generics.h
+include/xfce4/libxfce4util/xfce-kiosk.h
+include/xfce4/libxfce4util/xfce-miscutils.h
+include/xfce4/libxfce4util/xfce-rc.h
+include/xfce4/libxfce4util/xfce-resource.h
lib/libxfce4util.a
-lib/libxfce4util.la
lib/libxfce4util.so
lib/libxfce4util.so.1
libdata/pkgconfig/libxfce4util-1.0.pc
-share/xfce4/i18n/nls.alias
+sbin/xfce4-kiosk-query
+share/gtk-doc/html/libxfce4util/home.png
+share/gtk-doc/html/libxfce4util/index.html
+share/gtk-doc/html/libxfce4util/index.sgml
+share/gtk-doc/html/libxfce4util/left.png
+share/gtk-doc/html/libxfce4util/libxfce4util-Desktop-entries.html
+share/gtk-doc/html/libxfce4util/libxfce4util-File-Utilities.html
+share/gtk-doc/html/libxfce4util/libxfce4util-Internationalisation.html
+share/gtk-doc/html/libxfce4util/libxfce4util-Miscellaneous-Utilities.html
+share/gtk-doc/html/libxfce4util/libxfce4util-Resource-Config-File-Support.html
+share/gtk-doc/html/libxfce4util/libxfce4util-Resource-lookup-functions.html
+share/gtk-doc/html/libxfce4util/libxfce4util-Standard-Macros.html
+share/gtk-doc/html/libxfce4util/libxfce4util-Unicode-Support-Functions.html
+share/gtk-doc/html/libxfce4util/up.png
+share/gtk-doc/html/libxfce4util/libxfce4util-Xfce-Generics.html
+share/gtk-doc/html/libxfce4util/libxfce4util-Xfce-Kiosk-functions.html
+share/gtk-doc/html/libxfce4util/libxfce4util-core.html
+share/gtk-doc/html/libxfce4util/libxfce4util-datatypes.html
+share/gtk-doc/html/libxfce4util/libxfce4util-fundamentals.html
+share/gtk-doc/html/libxfce4util/libxfce4util-utilities.html
+share/gtk-doc/html/libxfce4util/libxfce4util.devhelp
+share/gtk-doc/html/libxfce4util/reference.html
+share/gtk-doc/html/libxfce4util/right.png
share/xfce4/m4/X11.m4
share/xfce4/m4/debug.m4
share/xfce4/m4/depends.m4
share/xfce4/m4/i18n.m4
@dirrm include/xfce4/libxfce4util
@unexec rmdir %D/include/xfce4 2>/dev/null || true
-@dirrm share/xfce4/i18n
+@dirrm share/gtk-doc/html/libxfce4util
+@unexec rmdir %D/share/gtk-doc/html 2>/dev/null || true
+@unexec rmdir %D/share/gtk-doc 2>/dev/null || true
@dirrm share/xfce4/m4
@unexec rmdir %D/share/xfce4 2>/dev/null || true
diff --git a/x11/xfce4-clipman-plugin/Makefile b/x11/xfce4-clipman-plugin/Makefile
index e438061d9a93..c0a5aaf92334 100644
--- a/x11/xfce4-clipman-plugin/Makefile
+++ b/x11/xfce4-clipman-plugin/Makefile
@@ -7,7 +7,7 @@
PORTNAME= xfce4-clipman-plugin
PORTVERSION= 0.4.0
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= x11 xfce
MASTER_SITES= http://download.berlios.de/xfce-goodies/ \
http://matt.nerim.net/xfce-goodies/ \
@@ -19,7 +19,7 @@ COMMENT= XFce 4 clipboard module for xfce4-panel
BUILD_DEPENDS= xfce4-panel:${PORTSDIR}/x11-wm/xfce4-panel
LIB_DEPENDS= xfce4util.1:${PORTSDIR}/x11/libxfce4util \
- xfcegui4.1:${PORTSDIR}/x11-toolkits/libxfce4gui \
+ xfcegui4.3:${PORTSDIR}/x11-toolkits/libxfce4gui \
xml2.5:${PORTSDIR}/textproc/libxml2 \
startup-notification-1.0:${PORTSDIR}/x11/startup-notification
RUN_DEPENDS= xfce4-panel:${PORTSDIR}/x11-wm/xfce4-panel
diff --git a/x11/xfce4-trigger-launcher/Makefile b/x11/xfce4-trigger-launcher/Makefile
index 8faa3caae57a..67a28c35fce5 100644
--- a/x11/xfce4-trigger-launcher/Makefile
+++ b/x11/xfce4-trigger-launcher/Makefile
@@ -6,11 +6,11 @@
#
PORTNAME= xfce4-trigger-launcher
-PORTVERSION= 4.0.5
-PORTREVISION= 1
+PORTVERSION= 4.2.0
CATEGORIES= x11 xfce
-MASTER_SITES= ftp://ftp.berlios.de/pub/xfce-goodies/${PORTVERSION}/ \
- http://hannelore.f1.fhtw-berlin.de/mirrors/xfce4/xfce-${PORTVERSION}/src/
+MASTER_SITES= http://www.us.xfce.org/archive/xfce-${PORTVERSION}/src/ \
+ http://spuriousinterrupt.org/projects/xfce4/files/mirror/xfce-${PORTVERSION}/ \
+ http://public.fh-wolfenbuettel.de/~luedickj/xfce4/xfce-${PORTVERSION}/
DISTNAME= xfce4-trigger-launcher-${PORTVERSION}
DIST_SUBDIR= xfce4
@@ -19,13 +19,13 @@ COMMENT= A command trigger plugin for xfce4-panel
BUILD_DEPENDS= xfce4-panel:${PORTSDIR}/x11-wm/xfce4-panel
LIB_DEPENDS= xfce4util.1:${PORTSDIR}/x11/libxfce4util \
- xfcegui4.1:${PORTSDIR}/x11-toolkits/libxfce4gui \
+ xfcegui4.3:${PORTSDIR}/x11-toolkits/libxfce4gui \
startup-notification-1.0:${PORTSDIR}/x11/startup-notification
RUN_DEPENDS= xfce4-panel:${PORTSDIR}/x11-wm/xfce4-panel
USE_GNOME= gtk20 libxml2
USE_X_PREFIX= yes
-USE_INC_LIBTOOL_VER= 13
+USE_LIBTOOL_VER=15
CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
.include <bsd.port.mk>
diff --git a/x11/xfce4-trigger-launcher/distinfo b/x11/xfce4-trigger-launcher/distinfo
index 7c9835b9d4a2..74814b0715ee 100644
--- a/x11/xfce4-trigger-launcher/distinfo
+++ b/x11/xfce4-trigger-launcher/distinfo
@@ -1,2 +1,2 @@
-MD5 (xfce4/xfce4-trigger-launcher-4.0.5.tar.gz) = 01812b93a4f072eec89f03d8dd2c20f8
-SIZE (xfce4/xfce4-trigger-launcher-4.0.5.tar.gz) = 332304
+MD5 (xfce4/xfce4-trigger-launcher-4.2.0.tar.gz) = 7162f20d0d43c905731ea15b4c4459dc
+SIZE(xfce4/xfce4-trigger-launcher-4.2.0.tar.gz) = 345902
diff --git a/x11/xfce4-trigger-launcher/pkg-plist b/x11/xfce4-trigger-launcher/pkg-plist
index 3723ba52da3a..87439d6d4a89 100644
--- a/x11/xfce4-trigger-launcher/pkg-plist
+++ b/x11/xfce4-trigger-launcher/pkg-plist
@@ -1,4 +1,3 @@
lib/xfce4/panel-plugins/libtriggerlauncher.so
-lib/xfce4/panel-plugins/libtriggerlauncher.la
-lib/xfce4/panel-plugins/libtriggerlauncher.a
@unexec rmdir %D/lib/xfce4/panel-plugins 2>/dev/null || true
+@unexec rmdir %D/lib/xfce4 2>/dev/null || true