aboutsummaryrefslogtreecommitdiffstats
path: root/x11
diff options
context:
space:
mode:
Diffstat (limited to 'x11')
-rw-r--r--x11/qt4-inputmethods/Makefile25
-rw-r--r--x11/qt4-inputmethods/pkg-descr2
-rw-r--r--x11/qt4-inputmethods/pkg-plist7
-rw-r--r--x11/qt4-opengl/Makefile33
-rw-r--r--x11/qt4-opengl/pkg-descr2
-rw-r--r--x11/qt4-opengl/pkg-plist12
6 files changed, 48 insertions, 33 deletions
diff --git a/x11/qt4-inputmethods/Makefile b/x11/qt4-inputmethods/Makefile
index 46f5fc3b75bb..6542bfdd9394 100644
--- a/x11/qt4-inputmethods/Makefile
+++ b/x11/qt4-inputmethods/Makefile
@@ -8,7 +8,6 @@
PORTNAME= inputmethods
PORTVERSION= ${QT4_VERSION}
-PORTREVISION= 0
CATEGORIES?= x11
PKGNAMEPREFIX= qt4-
@@ -29,22 +28,26 @@ MAKE_ENV?= QTDIR=${WRKSRC} LD_LIBRARY_PATH=${WRKSRC}/lib \
PATH=${WRKSRC}/bin:$$PATH
DO_NOT_EXTRACT= demos doc examples mkspecs qmake tools translations \
- src/dbus src/network src/opengl src/phonon \
- src/qt3support src/script src/sql src/svg src/testlib \
- src/tools src/xml src/xmlpatterns src/3rdparty/clucene \
- src/3rdparty/kdebase src/3rdparty/kdelibs src/3rdparty/webkit
+ src/activeqt src/dbus src/multimedia src/network src/opengl \
+ src/openvg src/phonon src/qt3support src/s60installs \
+ src/s60main src/script src/scripttools src/sql src/svg \
+ src/testlib src/tools src/winmain src/xml src/xmlpatterns \
+ src/3rdparty/clucene src/3rdparty/freetype \
+ src/3rdparty/libjpeg src/3rdparty/libmng src/3rdparty/libpng \
+ src/3rdparty/libtiff src/3rdparty/phonon src/3rdparty/webkit
EXTRACT_AFTER_ARGS= | ${TAR} -xf -
.for dne in ${DO_NOT_EXTRACT}
EXTRACT_AFTER_ARGS+= --exclude '${DISTNAME}/${dne}'
.endfor
-WRKSRC= ${WRKDIR}/${DISTNAME}/src/plugins/${PORTNAME}
-CONFIGURE_WRKSRC=${WRKSRC}/../../..
+BUILD_WRKSRC= ${WRKSRC}/src/plugins/${PORTNAME}
+INSTALL_WRKSRC= ${BUILD_WRKSRC}
+
+EXTRA_PATCHES= ${.CURDIR}/../../devel/qt4/files/patch-configure
pre-configure:
- ${CP} ${.CURDIR}/../../devel/qt4/files/configure ${CONFIGURE_WRKSRC}
- ${MKDIR} ${WRKSRC}/../../../mkspecs
- ${LN} -sf ${LOCALBASE}/bin/qmake-qt4 ${WRKSRC}/../../../bin/qmake
- ${LN} -sf ${LOCALBASE}/bin/moc-qt4 ${WRKSRC}/../../../bin/moc
+ ${MKDIR} ${WRKSRC}/mkspecs
+ ${LN} -sf ${LOCALBASE}/bin/qmake-qt4 ${WRKSRC}/bin/qmake
+ ${LN} -sf ${LOCALBASE}/bin/moc-qt4 ${WRKSRC}/bin/moc
.include <bsd.port.mk>
diff --git a/x11/qt4-inputmethods/pkg-descr b/x11/qt4-inputmethods/pkg-descr
index efc79b9aaf24..36bc69717e98 100644
--- a/x11/qt4-inputmethods/pkg-descr
+++ b/x11/qt4-inputmethods/pkg-descr
@@ -9,4 +9,4 @@ the application programmer with a single, common API for all operating systems.
The native C APIs are encapsulated in a set of well-designed, fully
object-oriented C++ classes.
-WWW: http://www.trolltech.com/products/qt/index.html
+WWW: http://qt.nokia.com/products/qt/index.html
diff --git a/x11/qt4-inputmethods/pkg-plist b/x11/qt4-inputmethods/pkg-plist
index bf964f3acbdb..3af105942e32 100644
--- a/x11/qt4-inputmethods/pkg-plist
+++ b/x11/qt4-inputmethods/pkg-plist
@@ -1,3 +1,4 @@
-lib/qt4/plugins/inputmethods/libqimsw-multi.so
-%%DEBUG%%lib/qt4/plugins/inputmethods/libqimsw-multi.so.debug
-@dirrm lib/qt4/plugins/inputmethods
+%%QT_PLUGINDIR_REL%%/inputmethods/libqimsw-multi.so
+%%DEBUG%%%%QT_PLUGINDIR_REL%%/inputmethods/libqimsw-multi.so.debug
+@dirrm %%QT_PLUGINDIR_REL%%/inputmethods
+@dirrmtry %%QT_PLUGINDIR_REL%%
diff --git a/x11/qt4-opengl/Makefile b/x11/qt4-opengl/Makefile
index 577538c13646..fe002c362cef 100644
--- a/x11/qt4-opengl/Makefile
+++ b/x11/qt4-opengl/Makefile
@@ -8,7 +8,6 @@
PORTNAME= opengl
PORTVERSION= ${QT4_VERSION}
-PORTREVISION= 0
CATEGORIES?= x11
PKGNAMEPREFIX= qt4-
@@ -19,12 +18,12 @@ USE_QT_VER= 4
QT_COMPONENTS= qmake_build moc_build corelib gui
QT_NONSTANDARD= yes
QT_DIST= yes
+MAKE_JOBS_SAFE= yes
HAS_CONFIGURE= yes
USE_LDCONFIG= ${PREFIX}/lib/qt4
USE_GL= glu
USE_XORG= x11
-MAKE_JOBS_SAFE= yes
ALL_TARGET= first
CONFIGURE_ENV?= QTDIR=${WRKSRC} PATH=${WRKSRC}/bin:$$PATH
@@ -32,31 +31,35 @@ MAKE_ENV?= QTDIR=${WRKSRC} LD_LIBRARY_PATH=${WRKSRC}/lib \
PATH=${WRKSRC}/bin:$$PATH
DO_NOT_EXTRACT= demos doc examples mkspecs qmake tools translations \
- src/dbus src/network src/phonon \
- src/qt3support src/script src/sql src/svg src/testlib \
- src/tools src/xml src/xmlpatterns src/3rdparty/clucene \
- src/3rdparty/kdebase src/3rdparty/kdelibs src/3rdparty/webkit
+ src/activeqt src/dbus src/multimedia src/network src/openvg \
+ src/phonon src/qt3support src/s60installs src/s60main \
+ src/script src/scripttools src/sql src/svg src/testlib \
+ src/tools src/winmain src/xml src/xmlpatterns \
+ src/3rdparty/clucene src/3rdparty/freetype \
+ src/3rdparty/libjpeg src/3rdparty/libmng src/3rdparty/libpng \
+ src/3rdparty/libtiff src/3rdparty/phonon src/3rdparty/webkit
EXTRACT_AFTER_ARGS= | ${TAR} -xf -
.for dne in ${DO_NOT_EXTRACT}
EXTRACT_AFTER_ARGS+= --exclude '${DISTNAME}/${dne}'
.endfor
-WRKSRC= ${WRKDIR}/${DISTNAME}/src/${PORTNAME}
-CONFIGURE_WRKSRC=${WRKSRC}/../../
+BUILD_WRKSRC= ${WRKSRC}/src/${PORTNAME}
+INSTALL_WRKSRC= ${BUILD_WRKSRC}
+
+CONFIGURE_ARGS+= -I../../include/Qt -I../../include
-CONFIGURE_ARGS+= -I../../include/Qt -I../../include
+EXTRA_PATCHES= ${.CURDIR}/../../devel/qt4/files/patch-configure
pre-configure:
- ${CP} ${.CURDIR}/../../devel/qt4/files/configure ${CONFIGURE_WRKSRC}
- ${MKDIR} ${WRKSRC}/../../mkspecs
- ${LN} -sf ${LOCALBASE}/bin/qmake-qt4 ${WRKSRC}/../../bin/qmake
- ${LN} -sf ${LOCALBASE}/bin/moc-qt4 ${WRKSRC}/../../bin/moc
+ ${MKDIR} ${WRKSRC}/mkspecs
+ ${LN} -sf ${LOCALBASE}/bin/qmake-qt4 ${WRKSRC}/bin/qmake
+ ${LN} -sf ${LOCALBASE}/bin/moc-qt4 ${WRKSRC}/bin/moc
post-configure:
${REINPLACE_CMD} -e 's|${PREFIX}/lib/qt4/pkgconfig|${PREFIX}/libdata/pkgconfig|g' \
- -e 's|.*$$(QMAKE).*||g' ${WRKSRC}/Makefile
+ -e 's|.*$$(QMAKE).*||g' ${BUILD_WRKSRC}/Makefile
${REINPLACE_CMD} -E -e 's|-L.[^[:space:]]*qt-x11-opensource.[^[:space:]]*lib||g' \
-E -e 's|(.*location=).*moc|\1${PREFIX}/bin/moc-qt4|g' \
- ${WRKSRC}/../../lib/pkgconfig/QtOpenGL.pc
+ ${WRKSRC}/lib/pkgconfig/QtOpenGL.pc
.include <bsd.port.mk>
diff --git a/x11/qt4-opengl/pkg-descr b/x11/qt4-opengl/pkg-descr
index efc79b9aaf24..36bc69717e98 100644
--- a/x11/qt4-opengl/pkg-descr
+++ b/x11/qt4-opengl/pkg-descr
@@ -9,4 +9,4 @@ the application programmer with a single, common API for all operating systems.
The native C APIs are encapsulated in a set of well-designed, fully
object-oriented C++ classes.
-WWW: http://www.trolltech.com/products/qt/index.html
+WWW: http://qt.nokia.com/products/qt/index.html
diff --git a/x11/qt4-opengl/pkg-plist b/x11/qt4-opengl/pkg-plist
index ca0a00ab3f6d..07a3b0d9bd9e 100644
--- a/x11/qt4-opengl/pkg-plist
+++ b/x11/qt4-opengl/pkg-plist
@@ -3,12 +3,18 @@ include/qt4/Qt/qgl.h
include/qt4/Qt/qglcolormap.h
include/qt4/Qt/qglframebufferobject.h
include/qt4/Qt/qglpixelbuffer.h
-include/qt4/Qt/glgc_shader_source.h
+include/qt4/Qt/qglscreen_qws.h
+include/qt4/Qt/qglshaderprogram.h
include/qt4/QtOpenGL/QGLColormap
include/qt4/QtOpenGL/QGLContext
include/qt4/QtOpenGL/QGLFormat
include/qt4/QtOpenGL/QGLFramebufferObject
+include/qt4/QtOpenGL/QGLFramebufferObjectFormat
include/qt4/QtOpenGL/QGLPixelBuffer
+include/qt4/QtOpenGL/QGLScreen
+include/qt4/QtOpenGL/QGLScreenSurfaceFunctions
+include/qt4/QtOpenGL/QGLShader
+include/qt4/QtOpenGL/QGLShaderProgram
include/qt4/QtOpenGL/QGLWidget
include/qt4/QtOpenGL/QMacCompatGLenum
include/qt4/QtOpenGL/QMacCompatGLint
@@ -19,7 +25,8 @@ include/qt4/QtOpenGL/qgl.h
include/qt4/QtOpenGL/qglcolormap.h
include/qt4/QtOpenGL/qglframebufferobject.h
include/qt4/QtOpenGL/qglpixelbuffer.h
-include/qt4/QtOpenGL/glgc_shader_source.h
+include/qt4/QtOpenGL/qglscreen_qws.h
+include/qt4/QtOpenGL/qglshaderprogram.h
lib/qt4/libQtOpenGL.la
lib/qt4/libQtOpenGL.prl
lib/qt4/libQtOpenGL.so
@@ -28,6 +35,7 @@ lib/qt4/libQtOpenGL.so.%%SHLIB_SHVER%%
lib/qt4/libQtOpenGL.so.%%SHLIB_VER%%
%%DEBUG%%lib/qt4/libQtOpenGL.so.%%SHLIB_VER%%.debug
libdata/pkgconfig/QtOpenGL.pc
+@dirrmtry lib/qt4
@dirrm include/qt4/QtOpenGL
@dirrmtry include/qt4/Qt
@dirrmtry include/qt4