aboutsummaryrefslogtreecommitdiffstats
path: root/x11
diff options
context:
space:
mode:
Diffstat (limited to 'x11')
-rw-r--r--x11/eaglemode/Makefile2
-rw-r--r--x11/scripts/Makefile2
-rw-r--r--x11/wbarconf/Makefile3
3 files changed, 3 insertions, 4 deletions
diff --git a/x11/eaglemode/Makefile b/x11/eaglemode/Makefile
index 3bbf096fd19b..51b18108f003 100644
--- a/x11/eaglemode/Makefile
+++ b/x11/eaglemode/Makefile
@@ -59,7 +59,7 @@ post-patch:
@${REINPLACE_CMD} -e 's|gcc|${CC}|; s|"-O2"|"${CFLAGS}"|' \
${WRKSRC}/makers/unicc/plugins/unicc_gnu.pm
@${FIND} ${WRKSRC} -name "*.pl" | ${XARGS} \
- ${REINPLACE_CMD} -e '1s|${perl_OLD_CMD}|${perl_CMD}|'
+ ${REINPLACE_CMD} -e '1s|/usr/bin/perl|${perl_CMD}|'
post-patch-XINE-off:
@${RM} -f ${WRKSRC}/makers/emAv.maker.pm
diff --git a/x11/scripts/Makefile b/x11/scripts/Makefile
index 96d6dcb403a9..8a140fc3adf1 100644
--- a/x11/scripts/Makefile
+++ b/x11/scripts/Makefile
@@ -15,6 +15,6 @@ USE_XORG= x11
USES= shebangfix
post-patch:
- @${REINPLACE_CMD} -e 's|XCOMM!${ksh_OLD_CMD}|XCOMM!${ksh_CMD}|' ${WRKSRC}/xauth_switch_to_sun-des-1.cpp
+ @${REINPLACE_CMD} -e 's|XCOMM!/bin/ksh|XCOMM!${ksh_CMD}|' ${WRKSRC}/xauth_switch_to_sun-des-1.cpp
.include <bsd.port.mk>
diff --git a/x11/wbarconf/Makefile b/x11/wbarconf/Makefile
index f5651a0162af..bc6d52870749 100644
--- a/x11/wbarconf/Makefile
+++ b/x11/wbarconf/Makefile
@@ -16,9 +16,8 @@ RUN_DEPENDS= wbar:${PORTSDIR}/x11/wbar
USE_GNOME= pygobject pygtk2 gtk20
USES= gettext desktop-file-utils python shebangfix
-SHEBANG_LANG= python
SHEBANG_FILES= ${WRKSRC}/wbarconf
-python_OLD_CMD= /usr/bin/env python2
+python_OLD_CMD= "/usr/bin/env python2"
NO_BUILD= yes
WRKSRC= ${WRKDIR}/${PORTNAME}
PORTDOCS= README COPYING