aboutsummaryrefslogtreecommitdiffstats
path: root/x11
diff options
context:
space:
mode:
Diffstat (limited to 'x11')
-rw-r--r--x11/hs-X11-xft/Makefile2
-rw-r--r--x11/hs-X11/Makefile15
-rw-r--r--x11/hs-xmobar/Makefile2
3 files changed, 17 insertions, 2 deletions
diff --git a/x11/hs-X11-xft/Makefile b/x11/hs-X11-xft/Makefile
index dc156b27a9e1..67e7086bb01e 100644
--- a/x11/hs-X11-xft/Makefile
+++ b/x11/hs-X11-xft/Makefile
@@ -2,7 +2,7 @@
PORTNAME= X11-xft
PORTVERSION= 0.3.1
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= x11 haskell
MAINTAINER= haskell@FreeBSD.org
diff --git a/x11/hs-X11/Makefile b/x11/hs-X11/Makefile
index 129a426c8a30..b410a3c8d135 100644
--- a/x11/hs-X11/Makefile
+++ b/x11/hs-X11/Makefile
@@ -3,6 +3,7 @@
PORTNAME= X11
PORTVERSION= 1.6.1.1
+PORTREVISION= 1
CATEGORIES= x11 haskell
MAINTAINER= haskell@FreeBSD.org
@@ -15,5 +16,19 @@ CABAL_SETUP= Setup.hs
USE_CABAL= data-default
USE_XORG= x11 xrandr xext
+OPTIONS_DEFINE= XINERAMA
+OPTIONS_DEFAULT= XINERAMA
+
+XINERAMA_DESC= Build with Xinerama support
+
+.include "${.CURDIR}/../../lang/ghc/bsd.cabal.options.mk"
+
+.if ${PORT_OPTIONS:MXINERAMA}
+USE_XORG+= xinerama
+CONFIGURE_ARGS+= --configure-option="--with-xinerama"
+.else
+CONFIGURE_ARGS+= --configure-option="--without-xinerama"
+.endif
+
.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
.include <bsd.port.mk>
diff --git a/x11/hs-xmobar/Makefile b/x11/hs-xmobar/Makefile
index 5edae089d5be..9bdae0f95902 100644
--- a/x11/hs-xmobar/Makefile
+++ b/x11/hs-xmobar/Makefile
@@ -3,7 +3,7 @@
PORTNAME= xmobar
PORTVERSION= 0.16
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= x11 haskell
MAINTAINER= haskell@FreeBSD.org