aboutsummaryrefslogtreecommitdiffstats
path: root/x11
diff options
context:
space:
mode:
Diffstat (limited to 'x11')
-rw-r--r--x11/xalf/Makefile10
1 files changed, 4 insertions, 6 deletions
diff --git a/x11/xalf/Makefile b/x11/xalf/Makefile
index 869a27f3af9f..725c3a93afd7 100644
--- a/x11/xalf/Makefile
+++ b/x11/xalf/Makefile
@@ -20,17 +20,15 @@ MAINTAINER= gnome@FreeBSD.org
USE_X_PREFIX= yes
USE_GMAKE= yes
-USE_GNOME= yes
+USE_GNOMENG= yes
+USE_GNOME= gnomeprefix gnomehack libcapplet
USE_LIBTOOL= yes
INSTALLS_SHLIB= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include" \
LIBS="-L${LOCALBASE}/lib -L${X11BASE}/lib"
-pre-patch:
- @${PERL} -pi -e 's|-lpthread|-pthread|g ; \
+post-patch:
+ @${REINPLACE_CMD} -e 's|-lpthread|-pthread|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
- @find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
- 's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
- s|\$\(datadir\)/locale|\$\(prefix\)/share/locale|g'
.include <bsd.port.mk>