aboutsummaryrefslogtreecommitdiffstats
path: root/x11
diff options
context:
space:
mode:
Diffstat (limited to 'x11')
-rw-r--r--x11/hs-X11/Makefile6
-rw-r--r--x11/hs-x11-ghc/Makefile6
2 files changed, 10 insertions, 2 deletions
diff --git a/x11/hs-X11/Makefile b/x11/hs-X11/Makefile
index f1c3999c3ee3..2e7cf06b8b5e 100644
--- a/x11/hs-X11/Makefile
+++ b/x11/hs-X11/Makefile
@@ -41,6 +41,9 @@ OPTIONS= XINERAMA "Build with Xinerama support" off
.if defined(WITH_XINERAMA)
USE_XORG+= xinerama
+CONFIGURE_ARGS+= --configure-option=--with-xinerama
+.else
+CONFIGURE_ARGS+= --configure-option=--without-xinerama
.endif
.if defined(NOPORTDOCS)
@@ -71,7 +74,8 @@ post-patch:
do-configure:
cd ${WRKSRC} && ${GHC_CMD} --make Setup.hs -o setup -package Cabal \
- && ${SETUP_CMD} configure --haddock-options=-w --prefix=${PREFIX}
+ && ${SETUP_CMD} configure --haddock-options=-w --prefix=${PREFIX} \
+ ${CONFIGURE_ARGS}
do-build:
cd ${WRKSRC} && ${SETUP_CMD} build \
diff --git a/x11/hs-x11-ghc/Makefile b/x11/hs-x11-ghc/Makefile
index f1c3999c3ee3..2e7cf06b8b5e 100644
--- a/x11/hs-x11-ghc/Makefile
+++ b/x11/hs-x11-ghc/Makefile
@@ -41,6 +41,9 @@ OPTIONS= XINERAMA "Build with Xinerama support" off
.if defined(WITH_XINERAMA)
USE_XORG+= xinerama
+CONFIGURE_ARGS+= --configure-option=--with-xinerama
+.else
+CONFIGURE_ARGS+= --configure-option=--without-xinerama
.endif
.if defined(NOPORTDOCS)
@@ -71,7 +74,8 @@ post-patch:
do-configure:
cd ${WRKSRC} && ${GHC_CMD} --make Setup.hs -o setup -package Cabal \
- && ${SETUP_CMD} configure --haddock-options=-w --prefix=${PREFIX}
+ && ${SETUP_CMD} configure --haddock-options=-w --prefix=${PREFIX} \
+ ${CONFIGURE_ARGS}
do-build:
cd ${WRKSRC} && ${SETUP_CMD} build \